Project

General

Profile

Feature #15227

VeraCrypt iteration 3: Support creating and modifying VeraCrypt volumes in GNOME

Added by segfault over 1 year ago. Updated 16 days ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/10/2017
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Starter:
Affected tool:

Subtasks

Feature #15049: Iteration 3: Support creating and modifying VeraCrypt volumes via udisksRejectedsegfault

Feature #15050: Iteration 3: Support creating and modifying VeraCrypt volumes in DisksRejectedsegfault

Feature #15038: Iteration 3: Clarify which version of the partition formatting dialog of Disks we should redesignRejectedsegfault

Feature #15229: Iteration 3: Support creating VeraCrypt file containersRejectedsegfault

Feature #15235: Iteration 3: Find out which Disks version we will have in TailsRejectedsegfault

Feature #15230: Iteration 3: Support creating and modifying VeraCrypt volumes in libblockdevRejectedsegfault

Feature #15240: Iteration 3: Write tests for creating and modifying VeraCrypt volumes in GNOMERejectedanonym

Feature #15241: Iteration 3: Upstream creating and modifying VeraCrypt volumes via udisksRejectedsegfault

Feature #15242: Iteration 3: Upstream creating and modifying VeraCrypt volumes in DisksRejectedsegfault

Feature #15243: Iteration 3: Upstream creating and modifying VeraCrypt volumes in libblockdevRejectedsegfault


Related issues

Related to Tails - Bug #16179: Research filesystems options to be usable accross Tails, Windows & MacOS X for Veracrypt Confirmed 12/02/2018

History

#1 Updated by segfault over 1 year ago

  • Related to Feature #15223: Iteration 2: Support unlocking VeraCrypt file containers in GNOME added

#2 Updated by segfault over 1 year ago

  • Related to deleted (Feature #15223: Iteration 2: Support unlocking VeraCrypt file containers in GNOME)

#3 Updated by segfault over 1 year ago

  • Blocked by Feature #15223: Iteration 2: Support unlocking VeraCrypt file containers in GNOME added

#4 Updated by segfault over 1 year ago

  • Blueprint set to https://tails.boum.org/blueprint/veracrypt#index5h2

#5 Updated by segfault over 1 year ago

  • Blocks Feature #15043: Iteration 4: Create VeraCrypt Mounter application added

#6 Updated by segfault over 1 year ago

  • Subject changed from Support creating and modifying VeraCrypt volumes in GNOME to Iteration 3: Support creating and modifying VeraCrypt volumes in GNOME

#7 Updated by intrigeri about 1 year ago

  • Target version deleted (Tails_3.9)

#8 Updated by sajolida about 1 year ago

I hereby propose that we reject entirely this iteration 3 and give higher priority to VeraCrypt Mounter.

#9 Updated by segfault about 1 year ago

sajolida wrote:

I hereby propose that we reject entirely this iteration 3 and give higher priority to VeraCrypt Mounter.

I agree. I would still like to do this, but the VeraCrypt Mounter is more important (for reference, see the discussion on #15628#note-5 and following).

#10 Updated by intrigeri about 1 year ago

sajolida wrote:

I hereby propose that we reject entirely this iteration 3 and give higher priority to VeraCrypt Mounter.

I agree. I would still like to do this, but the VeraCrypt Mounter is more important (for reference, see the discussion on #15628#note-5 and following).

I'll read that discussion in order to understand this proposal and then let's make a decision during our next meeting on Monday (worst case). Spoiler: I'm inclined to trust you on this one so unless I identify something you both have missed — unlikely — there's a good chance I'll agree :)

#11 Updated by intrigeri about 1 year ago

segfault wrote:

sajolida wrote:

I hereby propose that we reject entirely this iteration 3 and give higher priority to VeraCrypt Mounter.

I agree. I would still like to do this, but the VeraCrypt Mounter is more important (for reference, see the discussion on #15628#note-5 and following).

I have read #15628#note-5 and following and it seems to me that your (plural) conclusion is based on the analysis of the "File container without .hc extension" scenario.
FTR my analysis is slightly different (#15628#note-8) and does not logically imply that the lack of VeraCrypt Mounter would be such a big problem.
I'd like to discuss this and reach a common conclusion during our meeting tomorrow. But if you want to comment on Redmine, let's continue this discussion where it started (#15628).

#12 Updated by intrigeri about 1 year ago

intrigeri wrote:

I have read #15628#note-5 and following and it seems to me that your (plural) conclusion is based on the analysis of the "File container without .hc extension" scenario.
FTR my analysis is slightly different (#15628#note-8) and does not logically imply that the lack of VeraCrypt Mounter would be such a big problem.

But after discussing this topic a bit with segfault, regardless of how critical we think VeraCrypt Mounter is, I agree its more important than iteration 3.

#14 Updated by intrigeri about 1 year ago

  • Blocks deleted (Feature #15043: Iteration 4: Create VeraCrypt Mounter application)

#15 Updated by intrigeri 10 months ago

  • Subject changed from Iteration 3: Support creating and modifying VeraCrypt volumes in GNOME to VeraCrypt iteration 3: Support creating and modifying VeraCrypt volumes in GNOME
  • Parent task deleted (#14468)

#16 Updated by geb 9 months ago

  • Related to Bug #16179: Research filesystems options to be usable accross Tails, Windows & MacOS X for Veracrypt added

#17 Updated by segfault about 1 month ago

I think we can reject this. We don't have any budget anymore for the VeraCrypt project and I don't plan to work on this. @intrigeri, do you agree?

#18 Updated by intrigeri 16 days ago

I think we can reject this. We don't have any budget anymore for the VeraCrypt project and I don't plan to work on this. intrigeri, do you agree?

Absolutely, please reject all subtasks and then this ticket.

#19 Updated by segfault 16 days ago

  • Assignee deleted (segfault)

Redmine doesn't allow me to reject this ticket, even though I rejected all the subtickets

#20 Updated by intrigeri 16 days ago

Redmine doesn't allow me to reject this ticket, even though I rejected all the subtickets

That's because it's blocked by #15223. I'll fix that myself.

#21 Updated by intrigeri 16 days ago

  • Blocked by deleted (Feature #15223: Iteration 2: Support unlocking VeraCrypt file containers in GNOME)

#22 Updated by intrigeri 16 days ago

  • Status changed from Confirmed to Rejected

#23 Updated by segfault 16 days ago

intrigeri wrote:

Redmine doesn't allow me to reject this ticket, even though I rejected all the subtickets

That's because it's blocked by #15223. I'll fix that myself.

Thanks!

Also available in: Atom PDF