Project

General

Profile

Feature #15219

Feature #14468: Add VeraCrypt support to Tails

Feature #15214: Iteration 1: Support unlocking VeraCrypt partitions in GNOME

Iteration 1: Upstream unlocking VeraCrypt partitions in libblockdev

Added by segfault about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
01/25/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Blocked by Tails - Feature #15216: Iteration 1: Support unlocking VeraCrypt partitions in libblockdev Resolved 01/22/2018

History

#1 Updated by segfault about 2 years ago

  • Parent task changed from #15215 to #15214

#2 Updated by segfault about 2 years ago

  • Blocked by Feature #15216: Iteration 1: Support unlocking VeraCrypt partitions in libblockdev added

#3 Updated by segfault about 2 years ago

  • % Done changed from 100 to 0

#4 Updated by segfault about 2 years ago

  • Target version changed from Tails_3.7 to Tails_3.6

#5 Updated by segfault about 2 years ago

  • Subject changed from Upstream unlocking VeraCrypt partitions in libblockdev to Iteration 1: Upstream unlocking VeraCrypt partitions in libblockdev

#6 Updated by intrigeri almost 2 years ago

  • Status changed from Confirmed to In Progress

#8 Updated by bertagaz almost 2 years ago

  • Target version changed from Tails_3.6 to Tails_3.7

#9 Updated by segfault almost 2 years ago

  • Assignee changed from segfault to intrigeri
  • % Done changed from 0 to 100

The pull request was merged into libblockdev, so this is resolved. I seem to lack rights to close this ticket, could you do that intrigeri?

#10 Updated by intrigeri almost 2 years ago

  • Assignee changed from intrigeri to segfault

The pull request was merged into libblockdev, so this is resolved.

\o/

I seem to lack rights to close this ticket, could you do that intrigeri?

Nobody can close this ticket because it's marked as blocked by #15216 (is that one about writing the code or about having it working in a Tails branch? if the former, do we have a ticket about having the code working in Tails?).

I'll let you check the semantics of this relationship.

#11 Updated by segfault almost 2 years ago

  • Status changed from In Progress to Resolved

intrigeri wrote:

Nobody can close this ticket because it's marked as blocked by #15216

Oh, right.

(is that one about writing the code or about having it working in a Tails branch? if the former, do we have a ticket about having the code working in Tails?).

It's about writing the code, so I set it to "resolved". libblockdev is not packaged in Jessie, so for backporting I will have to redo this work in udisks, which is covered by #15253.

Also available in: Atom PDF