Project

General

Profile

Bug #15201

Disable Memory Hole for outgoing emails in Tails

Added by u about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
01/19/2018
Due date:
% Done:

100%

Feature Branch:
feature/15201-disable-enigmail-memory-hole
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

As decided on #13649, we should disable memory hole for outgoing emails in Tails by default.
This is currently a non issue, because we use torbirdy/stable.

But we should be proactive and explicitly disable the pref now, so we don't forget about it whenever we upgrade to Torbirdy 0.2.3 or newer for a totally unrelated reason (such as… switching to Debian testing :)


Related issues

Related to Tails - Feature #13649: Decide what to do with Memory Hole in Thunderbird Resolved 08/18/2017
Blocks Tails - Feature #13245: Core work 2018Q1: Foundations Team Resolved 06/29/2017
Blocked by Tails - Feature #15022: Electrum package update to version 3.0.6 Resolved 12/07/2017

Associated revisions

Revision ec0e6848 (diff)
Added by anonym almost 2 years ago

Thunderbird: explicitly disable Enigmail's Memory Hole feature.

It is already disabled in Enigmail by default, so at the moment this
is a NOP. But let's explicitly disable it (also in TorBirdy, which
controls the pref) so it is not enabled in case the default is
changed. We want to wait with enabling this until the time is right
since the current suboptimal implementations and lack of support
degrades UX too much.

Will-fix: #15201

Revision 1a0194da
Added by anonym almost 2 years ago

Merge remote-tracking branch 'origin/feature/15201-disable-enigmail-memory-hole' into devel

Fix-committed: #15201

History

#1 Updated by u about 2 years ago

  • Related to Feature #13649: Decide what to do with Memory Hole in Thunderbird added

#2 Updated by intrigeri almost 2 years ago

  • Target version changed from Tails_3.7 to Tails_3.6

I'd rather see this change applied in a major release with a RC. anonym, does that look doable? If not, please let me know ASAP and I'll try to find another way.

#3 Updated by intrigeri almost 2 years ago

#4 Updated by anonym almost 2 years ago

intrigeri wrote:

anonym, does that look doable?

Yes!

#5 Updated by anonym almost 2 years ago

  • Priority changed from Normal to Elevated

#6 Updated by anonym almost 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to bertagaz
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to feature/15201-disable-enigmail-memory-hole

#7 Updated by bertagaz almost 2 years ago

  • % Done changed from 50 to 90
  • QA Check changed from Ready for QA to Pass

Ok, works fine. I'd be ready to merge this branch, but it seems it contains commits from #15022 that are not yet merged into devel, so I'll wait for that to happen.

#8 Updated by bertagaz almost 2 years ago

  • Blocked by Feature #15022: Electrum package update to version 3.0.6 added

#9 Updated by anonym almost 2 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (bertagaz)
  • % Done changed from 90 to 100

bertagaz wrote:

Ok, works fine. I'd be ready to merge this branch, but it seems it contains commits from #15022 that are not yet merged into devel, so I'll wait for that to happen.

Whoops, sorry about that. Those commits are completely orthogonal, so we could just have dropped them. Any way, now #15022 is merged, so it's not an issue, and I went ahead and did the merge for you!

#10 Updated by bertagaz almost 2 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF