Project

General

Profile

Bug #15198

Feature #14568: Additional Software Packages

Convert ASP to Python3 and follow PEP-8

Added by u almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
01/19/2018
Due date:
% Done:

100%

Feature Branch:
feature/15198-asp-convert-to-python3-pep8
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

As noted on #14570:

According to PEP 8, one-line docstrings should have the closing """ on the same line.

I agree, but fixing it here without doing it in all the file looks wierd, so I propose to forget about it for now, and do it later on when converting this file to python3. I plan to do that after all branches are merged and tests are written.


Related issues

Blocked by Tails - Feature #14570: Implement Offline Mode for Additional Software Packages Resolved 01/17/2016
Blocked by Tails - Feature #14572: Implement automated tests for Additional Software/Offline Mode Resolved 08/30/2017 01/15/2018

Associated revisions

Revision 2abe4abb (diff)
Added by alant almost 2 years ago

ASP: convert to python3

No further changes are requires. Refs: #15198

Revision 1fc251b1 (diff)
Added by alant almost 2 years ago

ASP: fix coding style according to PEP-8

Refs: #15198

Revision 82bb83f7 (diff)
Added by bertagaz over 1 year ago

Fix python3 switch.

subprocess.Popen since Python 3.5 set STDIN and STDOUT output as binary,
unless its `universal_newlines` arg is set to True, in which case you
get text output that fits better with the way we parse this it later.

Refs: #15198

Revision 8469c983
Added by bertagaz over 1 year ago

Merge remote-tracking branch 'origin/feature/15198-asp-convert-to-python3-pep8' into devel

Fix-committed: #15198

History

#1 Updated by u almost 2 years ago

  • Related to Feature #14570: Implement Offline Mode for Additional Software Packages added

#2 Updated by alant almost 2 years ago

  • Subject changed from Convert ASP offline mode code to Python3 wrt PEP-8 to Convert ASP to Python3 and follow PEP-8

#3 Updated by alant almost 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from alant to segfault
  • QA Check set to Ready for QA
  • Feature Branch set to feature/15198-asp-convert-to-python3-pep8

This branch is ready. Please note it is based on feature/14572-automated-tests-for-ASP-offline-mode and should wait for it to be merged.

#5 Updated by u almost 2 years ago

  • Target version set to Tails_3.6

#6 Updated by u almost 2 years ago

  • Related to deleted (Feature #14570: Implement Offline Mode for Additional Software Packages)

#7 Updated by u almost 2 years ago

  • Blocked by Feature #14570: Implement Offline Mode for Additional Software Packages added

#8 Updated by u almost 2 years ago

  • Blocked by deleted (Feature #14570: Implement Offline Mode for Additional Software Packages)

#9 Updated by u almost 2 years ago

  • Blocked by Feature #14570: Implement Offline Mode for Additional Software Packages added

#10 Updated by u almost 2 years ago

  • Blocked by Feature #14572: Implement automated tests for Additional Software/Offline Mode added

#11 Updated by segfault almost 2 years ago

  • Assignee changed from segfault to anonym

Looks good to me. The only remaining ugly code is the f.closed in line 83, which has no effect.

#12 Updated by anonym almost 2 years ago

  • % Done changed from 0 to 50
  • QA Check changed from Ready for QA to Pass

segfault wrote:

Looks good to me.

Same! Not merging due to the blockers.

The only remaining ugly code is the f.closed in line 83, which has no effect.

Nice catch! I fixed it myself (b25e43c985eee068f3a8349ccb2e10a099ec10e7) and will keep this ticket until the blockers are merged or back on my plate.

#13 Updated by anonym almost 2 years ago

  • Assignee changed from anonym to bertagaz

anonym wrote:

I [...] will keep this ticket until the blockers are merged or back on my plate.

Actually that doesn't make sense. The blockers are on bert's plate, so this one should be as well. But only the merge remains!

#14 Updated by bertagaz over 1 year ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100

#15 Updated by bertagaz over 1 year ago

  • Assignee deleted (bertagaz)

bertagaz wrote:

Applied in changeset 8469c983425a0a3a47e38fbac9d7b47f24b8ce87.

With 82bb83f7 it works just fine, so it's meged into devel for 3.6. I don't know how people tested that though, adding '3' to the shebang wasn't enough clearly.

#16 Updated by bertagaz over 1 year ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF