Project

General

Profile

Feature #15197

Upgrade to Tor Browser 7.5

Added by anonym over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
01/18/2018
Due date:
% Done:

100%

Feature Branch:
feature/15197-tor-browser-7.5
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Related issues

Related to Tails - Feature #8243: Support meek bridges Confirmed 11/08/2014
Blocks Tails - Bug #13403: Can't print to file from Tor Browser when Tails session not in English Resolved 07/03/2017
Blocks Tails - Bug #15024: Tor Browser cannot print to file Resolved 12/08/2017

Associated revisions

Revision 13003794 (diff)
Added by anonym over 1 year ago

Upgrade Tor Browser to 7.5-build1.

Will-fix: #15197

Revision 1bfeb035 (diff)
Added by anonym over 1 year ago

Update Tor Browser release process for the 7.5 migration.

Refs: #15197

Revision d5f2ccf2 (diff)
Added by anonym over 1 year ago

Tor Browser: enable Selfrando.

Since Tor Browser 7.5, it is enabled in stable releases.

Refs: #15197

Revision 01e91eca (diff)
Added by anonym over 1 year ago

Upgrade Tor Browser to 7.5-build3.

There was a rebuild due to last minute Firefox changes.

Will-fix: #15197

Revision 00e426d2
Added by anonym over 1 year ago

Merge remote-tracking branch 'origin/feature/15197-tor-browser-7.5' into stable

Fix-committed: #13403, #15024, #15064, #15197

History

#1 Updated by anonym over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 50
  • Feature Branch set to feature/15197-tor-browser-7.5

Todo: run the full automated test suite after done with #15064.

#2 Updated by intrigeri over 1 year ago

  • Blocks Bug #13403: Can't print to file from Tor Browser when Tails session not in English added

#3 Updated by intrigeri over 1 year ago

  • Blocks Bug #15024: Tor Browser cannot print to file added

#4 Updated by u over 1 year ago

#5 Updated by anonym over 1 year ago

  • QA Check set to Ready for QA

I've imported the rebuild (7.5-build3).

#6 Updated by anonym over 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Passed all browser-using scenarios, except features/torified_browsing.feature:130 which is expected (but I took over the VM at the point of failure and manually verified the test).

#7 Updated by anonym over 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF