Project

General

Profile

Feature #15192

Activate Spanish on our website

Added by emmapeel over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
01/18/2018
Due date:
% Done:

100%

Feature Branch:
emmapeel:feature-15192-activate-spanish
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

The main weblate git repo is at:

http://translate.tails.boum.org/git/tails/index/

but it has files from many languages and a changed ikiwiki.setup file (to be able to create language files).

The Spanish files there are OK, but there are also other files on that repo.

My suggestion is:

- Check out Tails master and the translate repo
- Copy the Spanish translation files from the latter to the former. Commit.
- Change the ikiwiki setup file and others to add Spanish. Commit
- Build the wiki. Commit.

After this, the weblate repo should have tails master merged and changes on the Spanish files will have to go through the normal translator git workflow until we fix the weblate-git plugs

History

#1 Updated by emmapeel over 1 year ago

  • Assignee set to u

#2 Updated by emmapeel over 1 year ago

  • Feature Branch set to emmapeel:feature-15192-activate-spanish

Ok, I have:

  • copied the .es.po files to Tails master repo and made a branch out of it:
    https://git-tails.immerda.ch/emmapeel/tails/log/?h=feature-15192-activate-spanish.
    I did it with the command:
             find . -depth -type f -name '*.es.po' | cpio --pass-through 
             --preserve-modification-time  --make-directories --verbose 
             onlyspanishfolder
    
  • changed the ikiwiki configuration and ./build the website, which added some more new files, also committed to the branch
  • the website builds ok in my laptop, with spanish files on!!!

yay!!!

#3 Updated by u over 1 year ago

  • Target version set to Tails_3.6

#4 Updated by u over 1 year ago

  • Assignee changed from u to emmapeel

I built emmapeel's branch correclty but it seems I need to intervene. Two days ago I sent them an email but received no reply. intrigeri proposed to handle this issue instead of me. Reassigning to emmapeel so she can talk to whoever needs to be involved to make this happen.

#5 Updated by intrigeri over 1 year ago

  • Assignee changed from emmapeel to intrigeri

I'll handle it. Ideally during this cycle, but I cannot promise it (last time it was hours of work, partly because the branch I was given was incomplete and had broken stuff, but I trust it'll be better this time :)

#6 Updated by emmapeel over 1 year ago

Let me know when you want to do it to give you a newer set of files.

#7 Updated by intrigeri over 1 year ago

Let me know when you want to do it to give you a newer set of files.

Deal!

#8 Updated by emmapeel over 1 year ago

OK, I have a branch for you: is the branch es at https://0xacab.org/emmapeel/weblate.git

It is passing the check_po and builds the wiki

https://0xacab.org/emmapeel/weblate/pipelines?scope=branches&page=1

(it has some files for the gitlabconf)

#9 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF