Project

General

Profile

Feature #15159

Monitoring of our mirrors' ability to sync

Added by anonym over 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
01/09/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

After uploading Tails 3.4 it was discovered that something is broken on the Tor Project's side, in our mirroring setup. To prevent these last minute mirror problems about syncing, I wonder if we could add some simple monitoring. For instance: at the start of each day our rsync server creates a file with (with predictable name, e.g. today's date), and later in the day we check that each mirror has this expected file.


Related issues

Related to Tails - Bug #15162: Remove rsync.torproject.org from the mirrors synchronization chain Resolved 01/10/2018

History

#1 Updated by anonym over 1 year ago

  • Assignee set to bertagaz
  • Target version set to Tails_3.5

Does this make sense? (Setting a target release just so the ticket isn't lost)

#2 Updated by intrigeri over 1 year ago

As suggested on XMPP earlier today I think we should get rid of the torproject part of our mirroring rsync chain. Once this is done we have a subset of this monitoring for free since we already monitor our rsync server. I'll start a discussion with the mirrors & sysadmin teams about this later.

#3 Updated by intrigeri over 1 year ago

  • Related to Bug #15162: Remove rsync.torproject.org from the mirrors synchronization chain added

#4 Updated by anonym over 1 year ago

  • Target version changed from Tails_3.5 to Tails_3.6

#5 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7

#6 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (bertagaz)

intrigeri wrote:

As suggested on XMPP earlier today I think we should get rid of the torproject part of our mirroring rsync chain.

We're going to do it (#15162).

Once this is done we have a subset of this monitoring for free since we already monitor our rsync server.

Once #15162 is done, I think the monitoring we already have is good enough so I'm rejecting this. Let's reopen if we ever notice a problem that our existing monitoring does not catch.

Also available in: Atom PDF