Project

General

Profile

Bug #15141

Feature #5630: Reproducible builds

reproducibly_build_Tails_ISO_stable job erroneously fails when build reproduction succeeded

Added by intrigeri over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
01/02/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

Since yesterday the artifacts signing fails, which fails the build. I suspect this is caused by the upgrade of diffoscope to 90: apparently no empty diffoscope.txt is created anymore.

History

#1 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

#2 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to bertagaz
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

Seems to work when the ISO could be reproduced: https://jenkins.tails.boum.org/job/reproducibly_build_Tails_ISO_stable/98/. So I'll assume it works too when the ISO cannot be reproduced (my understanding is that the former case is more likely to trigger bugs in that script than the latter).

#3 Updated by anonym over 1 year ago

  • Target version changed from Tails_3.5 to Tails_3.6

#4 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7

#7 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#8 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#11 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (bertagaz)
  • % Done changed from 50 to 100
  • QA Check deleted (Ready for QA)

I've not seen this problem happen again and it feels futile to wait any longer for a review, so let's call it done.

Also available in: Atom PDF