Project

General

Profile

Feature #15139

Feature #13246: Core work

Feature #15138: Core work 2018Q2

Core work 2018Q2: Foundations Team

Added by intrigeri 12 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
01/01/2018
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Accounting
Blueprint:
Starter:
Affected tool:

Related issues

Blocked by Tails - Bug #15435: Consider upgrading Linux in Tails 3.7 Resolved 03/22/2018
Blocked by Tails - Bug #15436: Consider upgrading Linux in Tails 3.8 Resolved 03/22/2018
Blocked by Tails - Bug #15461: The homepage of the Unsafe Browser cannot be translated Resolved 03/27/2018
Blocked by Tails - Bug #15472: Rebase our Tor Browser AppArmor policy on top of torbrowser-launcher 0.2.9-2's Resolved 03/28/2018
Blocked by Tails - Bug #15468: Make the WhisperBack reports more helpdesk-friendly Resolved 03/28/2018
Blocked by Tails - Bug #15395: Enigmail & AppArmor: Cannot get key from keyserver after finding it Resolved 03/12/2018
Blocked by Tails - Bug #12152: Update tails-installer release process Resolved 01/17/2017
Blocked by Tails - Feature #15518: Upgrade tor to 0.3.3 Resolved 04/10/2018
Blocked by Tails - Bug #15391: Stop shipping python-qt4 that is no longer required Resolved 03/09/2018
Blocked by Tails - Feature #15530: Start upgrading to Tor Browser based on Firefox ESR60 Rejected 04/13/2018
Blocked by Tails - Bug #15532: devel branch FTBFS since virtualbox 5.2.8-dfsg-7 was uploaded to sid Resolved 04/13/2018
Blocked by Tails - Bug #15432: Tails Installer sometimes fails when setting partition type during (since Tails 3.6?) Resolved 03/21/2018
Blocked by Tails - Bug #15534: Update tails-bugs@boum.org OpenPGP key Resolved 04/15/2018
Blocked by Tails - Bug #15554: Upgrade Linux to 4.15.0-3 Resolved 04/26/2018
Blocked by Tails - Bug #15335: Adjust root terminal launcher on Buster wrt. the gksu removal Resolved 02/20/2018
Blocked by Tails - Bug #15607: Upgrade to Thunderbird 52.8.0 Resolved 05/19/2018
Blocked by Tails - Bug #15610: AppArmor breaks importing public OpenPGP keys from email attachments Resolved 05/21/2018
Blocked by Tails - Bug #15489: Inconsistencies in "release schedule" page Resolved 04/05/2018
Blocked by Tails - Bug #15616: devel branch FTBFS: xul-ext-ublock-origin is not installable Resolved 05/23/2018
Blocked by Tails - Bug #15621: devel branch FTBFS since virtualbox 5.2.12-dfsg-2 was uploaded to sid Resolved 05/26/2018
Blocked by Tails - Bug #15622: Upgrade to Linux 4.16+ in Tails 3.9 Resolved 05/28/2018
Blocked by Tails - Bug #15643: Upgrade Tor Browser to 7.5.5 Resolved 06/09/2018
Blocked by Tails - Bug #15683: Upgrade Tor Browser to 7.5.6 Resolved 06/24/2018

History

#1 Updated by intrigeri 12 months ago

#2 Updated by intrigeri 11 months ago

  • Blocked by Bug #11964: Discuss if Thunderbird AppArmor profile should prevent users from opening attachments added

#3 Updated by intrigeri 10 months ago

#4 Updated by intrigeri 10 months ago

  • Blocked by Feature #14404: Remove Vagrant cache-mechanism from build configuration as it might break on some filesystems added

#5 Updated by intrigeri 10 months ago

  • Blocked by Bug #15116: X.Org does not start with some NVidia Maxwell and Pascal graphic cards added

#6 Updated by intrigeri 9 months ago

  • Blocked by Bug #15435: Consider upgrading Linux in Tails 3.7 added

#7 Updated by intrigeri 9 months ago

  • Blocked by Bug #15436: Consider upgrading Linux in Tails 3.8 added

#8 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15116: X.Org does not start with some NVidia Maxwell and Pascal graphic cards)

#9 Updated by intrigeri 9 months ago

  • Blocked by Bug #15461: The homepage of the Unsafe Browser cannot be translated added

#10 Updated by intrigeri 9 months ago

  • Blocked by Feature #15281: Stack one single SquashFS diff when upgrading added

#11 Updated by intrigeri 9 months ago

  • Blocked by Bug #15173: Upgrade Intel processor microcodes to mitigate the Spectre attack added

#12 Updated by intrigeri 9 months ago

  • Blocked by Bug #14962: Tor Browser >= 7.0.8 fails to render local pages correctly added

#13 Updated by intrigeri 9 months ago

  • Blocked by Bug #15472: Rebase our Tor Browser AppArmor policy on top of torbrowser-launcher 0.2.9-2's added

#14 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15173: Upgrade Intel processor microcodes to mitigate the Spectre attack)

#15 Updated by intrigeri 9 months ago

  • Blocked by Bug #15468: Make the WhisperBack reports more helpdesk-friendly added

#16 Updated by intrigeri 9 months ago

  • Blocked by Bug #15470: Enigmail hides part of WhisperBack reports whose body includes an OpenPGP public key added

#17 Updated by intrigeri 8 months ago

  • Blocked by Bug #15418: Find out what's going on with Exim in our ISO build process added

#18 Updated by intrigeri 8 months ago

  • Blocked by Feature #12571: Find a nicer way to add exceptions from mandatory signing for our Tor Browser add-ons added

#19 Updated by intrigeri 8 months ago

  • Blocked by Bug #15395: Enigmail & AppArmor: Cannot get key from keyserver after finding it added

#20 Updated by intrigeri 8 months ago

  • Blocked by Feature #15331: Adapt to Tor's Sponsor4 Tor Launcher UX improvements: moat added

#21 Updated by intrigeri 8 months ago

  • Blocked by Bug #15254: Tails Installer breaks due to unicode status messages added

#22 Updated by intrigeri 8 months ago

  • Blocked by Bug #15042: Migrate away from our GNOME "AffectsTails" keyword added

#23 Updated by intrigeri 8 months ago

  • Blocked by Bug #12152: Update tails-installer release process added

#24 Updated by intrigeri 8 months ago

#25 Updated by intrigeri 8 months ago

  • Blocked by Bug #15391: Stop shipping python-qt4 that is no longer required added

#26 Updated by intrigeri 8 months ago

  • Blocked by Feature #15530: Start upgrading to Tor Browser based on Firefox ESR60 added

#27 Updated by intrigeri 8 months ago

  • Blocked by Feature #15531: Update plans and timeline wrt. upgrading to Tor Browser based on Firefox 60ESR added

#28 Updated by intrigeri 8 months ago

  • Blocked by Bug #15532: devel branch FTBFS since virtualbox 5.2.8-dfsg-7 was uploaded to sid added

#29 Updated by intrigeri 8 months ago

  • Blocked by Bug #15407: Prevent system user uid:s and gid:s from changing between releases added

#30 Updated by intrigeri 8 months ago

  • Blocked by Bug #15336: "The persistent Tor Browser directory is usable" test suite scenario is fragile added

#31 Updated by intrigeri 8 months ago

  • Blocked by Bug #15432: Tails Installer sometimes fails when setting partition type during (since Tails 3.6?) added

#32 Updated by intrigeri 8 months ago

  • Blocked by deleted (Bug #11964: Discuss if Thunderbird AppArmor profile should prevent users from opening attachments)

#33 Updated by intrigeri 8 months ago

  • Blocked by deleted (Bug #15336: "The persistent Tor Browser directory is usable" test suite scenario is fragile)

#34 Updated by intrigeri 8 months ago

  • Blocked by Bug #15534: Update tails-bugs@boum.org OpenPGP key added

#35 Updated by anonym 8 months ago

  • Blocked by Bug #15554: Upgrade Linux to 4.15.0-3 added

#36 Updated by intrigeri 8 months ago

  • Blocked by Bug #6907: ikiwiki po plugin does not play well with inline directives added

#37 Updated by intrigeri 8 months ago

  • Blocked by Bug #15335: Adjust root terminal launcher on Buster wrt. the gksu removal added

#38 Updated by intrigeri 7 months ago

  • Blocked by Bug #15607: Upgrade to Thunderbird 52.8.0 added

#39 Updated by intrigeri 7 months ago

  • Blocked by Bug #15610: AppArmor breaks importing public OpenPGP keys from email attachments added

#40 Updated by intrigeri 7 months ago

  • Blocked by Bug #15489: Inconsistencies in "release schedule" page added

#41 Updated by intrigeri 7 months ago

  • Blocked by Bug #15616: devel branch FTBFS: xul-ext-ublock-origin is not installable added

#42 Updated by intrigeri 7 months ago

#43 Updated by intrigeri 7 months ago

  • Blocked by Bug #11292: Bopomofo input for Chinese is not working added

#44 Updated by intrigeri 7 months ago

  • Blocked by deleted (Bug #14962: Tor Browser >= 7.0.8 fails to render local pages correctly)

#45 Updated by intrigeri 7 months ago

  • Blocked by Bug #15621: devel branch FTBFS since virtualbox 5.2.12-dfsg-2 was uploaded to sid added

#46 Updated by intrigeri 7 months ago

  • Blocked by deleted (Bug #15042: Migrate away from our GNOME "AffectsTails" keyword)

#47 Updated by intrigeri 7 months ago

  • Blocked by Bug #15622: Upgrade to Linux 4.16+ in Tails 3.9 added

#48 Updated by intrigeri 7 months ago

  • Blocked by Bug #15551: Generating a revocation certificate with Enigmail fails added

#49 Updated by intrigeri 7 months ago

  • Blocked by Bug #15014: Keys disappear from Seahorse after importing one added

#50 Updated by intrigeri 7 months ago

  • Blocked by deleted (Feature #15331: Adapt to Tor's Sponsor4 Tor Launcher UX improvements: moat)

#51 Updated by intrigeri 7 months ago

  • Blocked by deleted (Bug #15470: Enigmail hides part of WhisperBack reports whose body includes an OpenPGP public key)

#52 Updated by intrigeri 6 months ago

  • Blocked by Bug #15643: Upgrade Tor Browser to 7.5.5 added

#53 Updated by intrigeri 6 months ago

  • Blocked by Bug #15683: Upgrade Tor Browser to 7.5.6 added

#54 Updated by intrigeri 6 months ago

  • Blocked by deleted (Bug #15551: Generating a revocation certificate with Enigmail fails)

#55 Updated by intrigeri 6 months ago

  • Blocked by deleted (Bug #15418: Find out what's going on with Exim in our ISO build process)

#56 Updated by intrigeri 6 months ago

  • Blocked by deleted (Bug #11292: Bopomofo input for Chinese is not working)

#57 Updated by intrigeri 6 months ago

  • Blocked by deleted (Feature #12571: Find a nicer way to add exceptions from mandatory signing for our Tor Browser add-ons)

#58 Updated by intrigeri 6 months ago

  • Blocked by deleted (Bug #15407: Prevent system user uid:s and gid:s from changing between releases)

#59 Updated by intrigeri 6 months ago

  • Blocked by deleted (Feature #15281: Stack one single SquashFS diff when upgrading)

#60 Updated by intrigeri 6 months ago

  • Blocked by deleted (Bug #15254: Tails Installer breaks due to unicode status messages)

#61 Updated by intrigeri 6 months ago

#62 Updated by intrigeri 6 months ago

  • Blocked by deleted (Feature #15531: Update plans and timeline wrt. upgrading to Tor Browser based on Firefox 60ESR)

#63 Updated by intrigeri 6 months ago

  • Blocked by deleted (Bug #15014: Keys disappear from Seahorse after importing one)

#64 Updated by intrigeri 6 months ago

  • Blocked by deleted (Bug #11082: Replace Liferea)

#65 Updated by intrigeri 6 months ago

  • Blocked by deleted (Bug #6907: ikiwiki po plugin does not play well with inline directives)

#66 Updated by intrigeri 5 months ago

  • Blocked by deleted (Feature #14404: Remove Vagrant cache-mechanism from build configuration as it might break on some filesystems)

#67 Updated by intrigeri 5 months ago

#68 Updated by u 4 months ago

Seems like this ticket could be closed.

#69 Updated by intrigeri 4 months ago

  • Status changed from Confirmed to Fix committed

u wrote:

Seems like this ticket could be closed.

Nope, it's blocked by tickets that will remain open until 3.9 is out.

#70 Updated by intrigeri 4 months ago

  • Target version set to Tails_3.9

#71 Updated by intrigeri 3 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF