Project

General

Profile

Feature #15122

Feature #14548: Fix issues identified in the expert review done by jaster on our installation instructions

Rename Tails Greeter to be more plain

Added by sajolida over 2 years ago. Updated 1 day ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
12/27/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Greeter

Description

During the expert review, "Tails Greeter" wasn't an intuitive name. She would have preferred "Tails Welcome Screen" or something similar.

I understand that "Greeter" comes from the backend technology from GNOME.

We could check how other projects are calling such screens.


Related issues

Related to Tails - Feature #15260: Clarify what is Tails Greeter in the documentation of each additional setting Resolved 01/29/2018
Related to Tails - Feature #14544: Spend software developer time on smallish UX improvements In Progress 08/31/2018
Blocks Tails - Bug #17136: Persistence preset: Greeter settings In Progress
Blocks Tails - Feature #17247: Core work 2020Q1 → 2020Q2: Technical writing Confirmed

History

#1 Updated by sajolida about 2 years ago

During the Additional Software UX sprint, a participant wondered what Tails Greeter was but quickly guessed it was the welcoming screen.

#2 Updated by sajolida about 2 years ago

  • Subject changed from Renaming Tails Greeter to be more plain to Rename Tails Greeter to be more plain

Two participants :)

#3 Updated by sajolida about 2 years ago

  • Related to Feature #15260: Clarify what is Tails Greeter in the documentation of each additional setting added

#4 Updated by sajolida 5 months ago

  • Related to Feature #14544: Spend software developer time on smallish UX improvements added

#5 Updated by intrigeri about 2 months ago

Alan says that if the scope is limited to changing the window title in the Greeter's GUI, then it's really simple implementation-wise, once we know what the new string should be.

#6 Updated by sajolida about 1 month ago

  • Type of work changed from User interface design to End-user documentation

Hmm... Actually, it seems like the word "Greeter" is not used anywhere
in user-facing strings in the code. Then, this change only makes sense
in the documentation on the website.

We could call it "the Welcome Screen" and not change a ting in the code.
This would become a job for the Technical Writing team.

@cbrownstein: What do you think?

#7 Updated by sajolida 28 days ago

  • Related to Bug #17136: Persistence preset: Greeter settings added

#8 Updated by cbrownstein 24 days ago

I think "Welcome Screen" is more familiar than "Greeter" and I think it makes sense to update the documentation.

#9 Updated by sajolida 18 days ago

  • Related to deleted (Bug #17136: Persistence preset: Greeter settings)

#10 Updated by sajolida 18 days ago

  • Blocks Bug #17136: Persistence preset: Greeter settings added

#11 Updated by sajolida 15 days ago

  • Blocks Feature #17247: Core work 2020Q1 → 2020Q2: Technical writing added

#12 Updated by sajolida 14 days ago

@intrigeri: Here a patch for puppet-tails.git for once 4.5 is out.

@cbrownstein: I also worked on this as part of doc/17492-secure-boot (I'll push it when I'm done with #17492) because I was touching the same files already to adjust to Secure Boot. Sorry for the huge branch! But I made nice commits, hopefully. The commits for this ticket are 533c1b1bc7 and e257c1fbee.

  • I left "Greeter" in internal documents (blueprint) and very old news.
  • 'Welcome Screen' formatted as a feature, like Persistent Storage. I'll document better these things in #16221.

#13 Updated by sajolida 14 days ago

@intrigeri: Ah, and shall we rename "Greeter" into "Welcome Screen" on Redmine as well? I leave it up to you.

#14 Updated by sajolida 14 days ago

  • Blocked by Feature #17492: Update documentation wrt. using GRUB + Secure Boot for USB boot on EFI 64-bit added

#15 Updated by intrigeri 14 days ago

Hi,

Here a patch for puppet-tails.git for once 4.5 is out.

LGTM. I'm tracking this in my org-mode. Is it fine if I do this in the few days that follow the release, as opposed to "in the next few minutes/hours"?

Ah, and shall we rename "Greeter" into "Welcome Screen" on Redmine as well? I leave it up to you.

I see that you've renamed "Greeter" into "Welcome Screen" in the contributors doc too, so IMO we should do the same in Redmine/GitLab. I'm tracking this locally as well.

#16 Updated by sajolida 14 days ago

Is it fine if I do this in the few days that follow the release, as opposed to "in the next few minutes/hours"?

Yes!

I see that you've renamed "Greeter" into "Welcome Screen" in the contributors doc too, so IMO we should do the same in Redmine/GitLab. I'm tracking this locally as well.

Great. I had a note about asking you to do this but apparently I lost it
half-way through :)

#17 Updated by cbrownstein 4 days ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from cbrownstein to sajolida

Looks good!

#18 Updated by sajolida 1 day ago

  • Blocked by deleted (Feature #17492: Update documentation wrt. using GRUB + Secure Boot for USB boot on EFI 64-bit)

#19 Updated by sajolida 1 day ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

Also available in: Atom PDF