Project

General

Profile

Feature #15076

Feature #10034: Translation web platform

Test the set up of the translation platform

Added by u over 1 year ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
12/19/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:

Description

- subscription
- translating
- reviewing
- commits & commit messages to weblate Git

History

#2 Updated by u over 1 year ago

  • Target version set to Tails_3.6

#3 Updated by emmapeel over 1 year ago

I am testing this but is a moving target, specially if we are to do #15274 soon.

But the server can:

- subscribe new users with email confirmation link

- send optional email notifications for:

  • Component wide notifications - In your watched projects
    • merge failure
    • new language request
    • Translation notifications
  • Only for your translated languages in your watched projects
    • on any translation
    • on new string to translate
    • on new suggestion
    • on new contributor
    • on new comment

Messages get committed to the repo. Not sure what else to test there but this is working quite OK.

Regarding reviews the current situation is like this:

  • Suggestions don't change the file.
  • File changes are done when a translation gets approved ('saved') by an admin, or 2 users voting for it.
  • Anonymous users can suggest but they still need to get 2 votes from registered users to get a translation accepted.
  • Commits are lazy, so you should not get many for each file. They can be triggered by hand, or will happen if changing translator or pulling from Tails master.

But is bound to change with the upgrade.

#4 Updated by emmapeel over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7

#5 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#6 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#7 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

#8 Updated by intrigeri 11 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#9 Updated by CyrilBrulebois 9 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#10 Updated by u 8 months ago

I'm not sure this ticket makes sense anymore. Feel free to close it.

#11 Updated by anonym 8 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#12 Updated by emmapeel 7 months ago

  • Status changed from Confirmed to Resolved

ok! closing as resolved, because testing has been done

#13 Updated by intrigeri 3 months ago

  • Assignee deleted (emmapeel)

Also available in: Atom PDF