Project

General

Profile

Feature #15039

Feature #14468: Add VeraCrypt support to Tails

Feature #15223: Iteration 2: Support unlocking VeraCrypt file containers in GNOME

Feature #15224: Iteration 2: Support unlocking VeraCrypt file containers in Nautilus

Iteration 2: Icon for .hc and .tc file extension

Added by sajolida almost 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
12/10/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Graphics
Blueprint:
Starter:
Affected tool:

Description

We want to associated the .tc and .hc file extensions with our VeraCrypt integration in GNOME Files and need an icon for that. Licensing issues might be at stake here as well.

triangles.svg View (14.6 KB) u, 01/16/2018 04:32 PM


Related issues

Related to Tails - Feature #15680: Icon for VeraCrypt Mounter Resolved 06/20/2018

History

#2 Updated by u almost 2 years ago

FYI as inspiration:

→ IMO it would be nice to use the aesthetics of the Veracrypt icon (blue and green triangles) to recreate a key logo such as the TC one above (while the original uses dots). For the hidden container logo one could simply but the key logo under a roof, a bit like a chinese character :)

Or: make the TC logo show the key and the HC logo use a transparent key while outlining the container :)

#3 Updated by u almost 2 years ago

Very rough sketch.

#4 Updated by segfault over 1 year ago

  • Parent task changed from #14464 to #15224

#5 Updated by anonym over 1 year ago

  • Target version changed from Tails_3.5 to Tails_3.6

#6 Updated by segfault over 1 year ago

  • Subject changed from Icon for .hc and .tc file extension to Iteration 2: Icon for .hc and .tc file extension

#7 Updated by sajolida over 1 year ago

  • Priority changed from Normal to Low
  • Target version deleted (Tails_3.6)

I think this is low priority and I'll work on this if I have extra time later on in the project.

Also, since I don't understand u's proposal let me clarify that we're looking here to create an icon that would fit as a file icon in GNOME Files, see attachment. Unless we can't do it because of licensing issues, I would reuse the VeraCrypt icon and put inside a similar form as used for .ods, .pdf, etc.

But seeing that even PDFs don't have a dedicated icon in GNOME Files, not having something specific for VeraCrypt containers wouldn't be a major issue.

#8 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (sajolida)

I won't have extra time.

#9 Updated by segfault over 1 year ago

Also available in: Atom PDF