Project

General

Profile

Bug #15021

MacBookPro won’t boot Tails, other live distros do

Added by huertanix almost 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
-
Start date:
12/07/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

During a Tails workshop with a human rights organization, we ran into a problem booting a Tails 3.3 intermediate drive, which we created by using dd after downloading and checking the file’s PGP signature to make sure the iso image wasn’t corrupted.

Participants had MacBookPro 13,2 and MacBookPro 14,3 models, and in the built-in Apple boot selector, none of them showed the USB device as a boot option—only Macintosh HD showed up as an option. Other live Linux distributions created using the same dd command worked, including Kali Linux (created with dd the same way the Kali distro was) and Black Arch (created with Etcher.io). The USB model we used to created a Kali and Tails drive was a Micro Center USB 3.0 8GB drive, same model type, but only the Kali one worked. The Black Arch drive was also a Micro Center USB 3.0 drive, but a 32GB model.

We didn’t anticipate we’d run into this problem since there was no mention of it being an issue in https://tails.boum.org/support/known_issues/. Any idea what the problem is and why Kali and Black Arch are not affected and Tails OS is? One of the Tails drives created worked on a Thinkpad x140e, so we suspect this is due to a lack of hardware support for the new Macbook Pros, which unfortunately is all this organization has.


Related issues

Related to Tails - Bug #15025: Document that Tails installed using dd is not seen as a bootable device on some MacBook Pro Resolved 12/08/2017

History

#1 Updated by intrigeri almost 2 years ago

huertanix wrote:

Participants had MacBookPro 13,2 and MacBookPro 14,3 models, and in the built-in Apple boot selector, none of them showed the USB device as a boot option—only Macintosh HD showed up as an option.

Thanks! I've added this info to #12146 where we're tracking this class of Mac problems.

We didn’t anticipate we’d run into this problem since there was no mention of it being an issue in https://tails.boum.org/support/known_issues/.

Sorry about that. We knew there were such problems on some Macs, but we hadn't enough info so far to realize how many different Macs were affected: for example, it's the first time I hear about it for these two models. I'll file a ticket for our tech writers so they consider documenting this issue.

Any idea what the problem is and why Kali and Black Arch are not affected and Tails OS is?

No, but it's very useful info! I've added this to #12146 and it might help me implement a quick workaround without blocking on the nicer, harder solution.

#2 Updated by intrigeri almost 2 years ago

  • Related to Bug #15025: Document that Tails installed using dd is not seen as a bootable device on some MacBook Pro added

#3 Updated by intrigeri almost 2 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF