Project

General

Profile

Bug #14982

Fix OpenPGP Applet vs. Tails ticket tracking workflow

Added by intrigeri over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
11/18/2017
Due date:
% Done:

10%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:
OpenPGP Applet

Description

Upstream OpenPGP Applet uses this Redmine project to track its tickets. #6398 has shown that if the same semantics are used for OpenPGP Applet as the ones we use for Tails, ticket state gets too easily messed up: in this case, a ticket was "fix committed" upstream but not in Tails.

So either OpenPGP Applet should avoid using ticket status semantics differently than Tails tickets, or OpenPGP Applet should migrate to another ticket tracker (e.g. another project on this Redmine instance, of some GitLab instance somewhere).

I propose we move the OpenPGP Applet project (tickets, Git & merge requests handling) to https://gitlab.com/.

History

#1 Updated by intrigeri over 2 years ago

  • Description updated (diff)

(https://0xacab.org/ is too painful: one can't easily fork a project to submit a MR.)

#2 Updated by nodens over 2 years ago

I'm fine with gitlab.com, however it'd be worth it to see if salsa.debian.org ends up having tickets enabled, since the upstream web page is supposed to migrate from alioth to there.

Or, I propose we migrate everything on gitlab.com, including the homepage - but there is still the issue of the mailing list.

#3 Updated by nodens over 2 years ago

So apparently the issue tracker is enabled.
I created https://salsa.debian.org/openpgp-applet/openpgp-applet to test a bit. Beware, the data will probably be reset at least once before salsa enter the "beta" stage.

In any case, we'll want to recreate issues on gitlab, and refer to them here (leaving a link to the new issue).

#4 Updated by intrigeri over 2 years ago

So apparently the issue tracker is enabled.
I created https://salsa.debian.org/openpgp-applet/openpgp-applet to test a bit. Beware, the data will probably be reset at least once before salsa enter the "beta" stage.

OK, then let's wait a bit for salsa.d.o to enter production state.
Is there any ETA?

#5 Updated by intrigeri over 2 years ago

Also, what will be the steps for a pass-by contributor to create an account and fork a repo in order to submit a MR?

#6 Updated by nodens over 2 years ago

OK, then let's wait a bit for salsa.d.o to enter production state.
Is there any ETA?

Last time I talked about it with formorer, it was supposed to be before the end of 2017 (actually, it should have happened already actually).
I think the self-registration page for guest account isn't quite ready, hence the delay.

Also, what will be the steps for a pass-by contributor to create an account and fork a repo in order to submit a MR?

There will be a self-registration page to create guest (i.e. non debian) account. Mine was created manually but that's not the definitive process of course :)

Once you have an account, you have your own namespace to create projects, and you can even create groups (that's how I created the test project linked above, I also gave you access using your debian account).

So the steps would be:
  • register if needed
  • fork

that's pretty much it. Of course forking elsewhere (gitlab.com, github...) is possible as well, but less straightforward.

#7 Updated by intrigeri over 2 years ago

So the steps would be:
  • register if needed
  • fork

Perfect, as long as the registration is smooth (e.g. does not require to wait for a human to accept it).

#8 Updated by Anonymous about 2 years ago

We should define a better workflow - might be cheaper than moving around the repository.
I volunteered to explain to nodens how we do it with other Tails specific packages.

#9 Updated by intrigeri about 2 years ago

I volunteered to explain to nodens how we do it with other Tails specific packages.

Note one important difference:

  • These other Tails specific packages are always updated in Tails first (via our custom APT repo), so the workflow we generally use on Redmine works just fine: ticket "upstream" status == ticket status in Tails.
  • We install OpenPGP Applet from Debian, so wrt. bug/feature tracking it is more like any other package that we install from Debian, regardless of the fact we happen to be upstream for this one; this is the mismatch that makes it hard to track OpenPGP Applet status here (e.g. does "Fix committed" mean "there's a fix in upstream Git" or "the fix has been applied in current Tails devel branch somehow"?), which prompted me to create this ticket in the first place (see #6398 whose current status is correct from an upstream PoV, but wrong from a Tails PoV, because we're trying to track both with a single metadata field, which of course is problematic).

This is why I doubt the solutions that work for other Tails specific packages would work for OpenPGP Applet. I'd be happy to be proven wrong though :)

#10 Updated by anonym about 2 years ago

  • Target version changed from Tails_3.5 to Tails_3.6

#11 Updated by nodens about 2 years ago

  • QA Check changed from Info Needed to Dev Needed

Just FYI, since salsa.debian.org just got out of beta, I'm planning to finish the repo move today or tommorrow.
The issues and website etc will follow.

#12 Updated by nodens about 2 years ago

  • Status changed from In Progress to Confirmed
  • Assignee changed from nodens to intrigeri
  • QA Check changed from Dev Needed to Info Needed

This is now done.
Most issues have been duplicated on Salsa, unless there is some undergoing work not available in upstream repo, or if they are relevant to Tails only.

All issues have been updated to notify people about this.
The one that are not specific to Tails have been marked as resolved:
#14925
#14808
#12466
#13602
#11746
#12190
#7434
#7433

I'm not sure "resolved" is the correct status for this. There is no "upstream" flag here, maybe we should leave them open until it's actually fixed in Tails ?

Other issues are either specific to Tails, or have work in progress with code not available on Salsa. Those have been update to give people a chance to move their work to Salsa, or at least create an issue there with relevant links.

Of course, I'll continue to track issues related to OpenPGP applet created here, but those should now be only the one that affect Tails' users (unless they have an old version and the instructions to report issues are obsolete).

Cheers,

#13 Updated by intrigeri about 2 years ago

  • Status changed from Confirmed to Resolved

This is now done.

\o/

I'm not sure "resolved" is the correct status for this. There is no "upstream" flag here,

I've changed them to "Duplicate".

maybe we should leave them open until it's actually fixed in Tails ?

We sometimes do that when we feel the need to specifically track a given upstream issue on our side but I don't think it's worth the overhead in this case.

Also available in: Atom PDF