Project

General

Profile

Feature #14925

AppIndicator Support for OpenPGP Applet

Added by inverse.chi over 2 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
11/06/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
OpenPGP Applet

Description

Since upgrading to Ubuntu 17.10 I am no longer able to use the OpenPGP Applet.

From what I've been informed supporting AppIndicator should be simple or is the issue deeper than this?

https://github.com/ubuntu/gnome-shell-extension-appindicator/issues/105#issuecomment-341136565


Related issues

Duplicates Tails - Bug #8310: Convert OpenPGP Applet into a proper GNOME Shell extension In Progress 11/16/2016

History

#1 Updated by mercedes508 over 2 years ago

  • Assignee set to goupille

#2 Updated by goupille over 2 years ago

  • Assignee changed from goupille to nodens

#3 Updated by nodens over 2 years ago

  • Status changed from New to Confirmed
  • Affected tool set to OpenPGP Applet

#4 Updated by nodens over 2 years ago

  • Tracker changed from Bug to Feature
  • Assignee deleted (nodens)
  • Priority changed from Normal to Low

Hello,

There is no plan to implement AppIndicator Support, sorry.

Regarding the usage with recent versions of gnome, for now we use the TopIcons Plus extension as proposed in the Github issue.

In the future, we plan to implement a DBus backend and a proper Gnome extension (#8310) - of course, other methods of notification can then use the DBus backend. The legacy system - using notification area - should stay available for compatibilty with other desktop environments.

I'll leave this issue open, in the feature tracker, with a low priority, in case someone wants to implement this.

Cheers,

nodens

#5 Updated by Anonymous about 2 years ago

  • Subject changed from AppIndicator Support to AppIndicator Support for OpenPGP Applet

#6 Updated by nodens about 2 years ago

  • Status changed from Confirmed to Resolved

Hi,

OpenPGP applet is moving to its new home on https://salsa.debian.org/openpgp-applet-team/openpgp-applet

This issue has been duplicated upstream: https://salsa.debian.org/openpgp-applet-team/openpgp-applet/issues/11

I'm closing this one. Feel free to comment on the upstream link!

You will need an account on Salsa. If you don't have one already, you can create one on https://signup.salsa.debian.org/.

Cheers!

#7 Updated by intrigeri about 2 years ago

  • Status changed from Resolved to Duplicate

#8 Updated by intrigeri 11 months ago

  • Duplicates Bug #8310: Convert OpenPGP Applet into a proper GNOME Shell extension added

Also available in: Atom PDF