Project

General

Profile

Bug #14923

devel branch FTBFS since torbrowser-launcher 0.2.8-4 was uploaded

Added by intrigeri over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
11/06/2017
Due date:
% Done:

100%

Feature Branch:
bugfix/14923-refresh-Tor-Browser-AppArmor-profile
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Related to Tails - Bug #14935: Future-proof the test suite vs future fundraising campaign headers Resolved 11/08/2017
Blocks Tails - Feature #13244: Core work 2017Q4: Foundations Team Resolved 06/29/2017
Blocks Tails - Bug #14924: reproducibly_build_Tails_ISO_stable Jenkins job always fails Resolved 11/06/2017

Associated revisions

Revision 63ebac31 (diff)
Added by intrigeri over 1 year ago

Refresh Tor Browser AppArmor profile patch to apply on top of torbrowser-launcher 0.2.8-4's (refs: #14923).

Revision 680b9a04
Added by anonym over 1 year ago

Merge remote-tracking branch 'origin/feature/14789-linux-4.13' into stable

Fix-committed: #14714, #14789, #14923

History

#1 Updated by intrigeri over 1 year ago

#2 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/14923-refresh-Tor-Browser-AppArmor-profile

#3 Updated by intrigeri over 1 year ago

  • % Done changed from 10 to 20

The branch builds fine. I've started a full test suite run on it to ensure I didn't mess up the AppArmor profile in a way that would break Tor Browser.

#4 Updated by intrigeri over 1 year ago

I'll have to test some stuff manually (likely due to a regression introduced in our test suite last month: #14929).

#5 Updated by intrigeri over 1 year ago

I've "run" the I can view a file stored in "~/Tor Browser" but not in ~/.gnupg scenario by hand and it works fine.

#6 Updated by intrigeri over 1 year ago

  • % Done changed from 20 to 30

Crap, my full test suite run failed with the 60 min timeout somewhere in features/torified_gnupg.feature, so torified_misc.feature, totem.feature, features/unsafe_browser.feature and features/virtualization.feature were not run. I don't think they're affected by the Tor Browser AppArmor profile so I'll ignore this. Relevant scenario failures:

  • "The persistent Tor Browser directory is usable": the page is loaded but the fundraising header looks is buggy. I'll test manually.
  • "Persistent browser bookmarks": looks like a test suite / dogtail bug, will test manually.

#7 Updated by intrigeri over 1 year ago

  • Blocks Bug #14924: reproducibly_build_Tails_ISO_stable Jenkins job always fails added

#8 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 30 to 50
  • QA Check set to Ready for QA

intrigeri wrote:

Relevant scenario failures:

  • "The persistent Tor Browser directory is usable": the page is loaded but the fundraising header looks is buggy. I'll test manually.

Same when testing by hand: no AppArmor problem so we're good as far as this branch is concerned, but indeed this automated test is broken by the fundraising campaign header. Will report this separately.

  • "Persistent browser bookmarks": looks like a test suite / dogtail bug, will test manually.

Passed on my local Jenkins after retrying.

#9 Updated by intrigeri over 1 year ago

  • Related to Bug #14935: Future-proof the test suite vs future fundraising campaign headers added

#10 Updated by anonym over 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#11 Updated by anonym over 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF