Project

General

Profile

Bug #14857

Some doc branches fail to build an ISO because the base branch of master is "testing" after a major release

Added by intrigeri almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
10/17/2017
Due date:
% Done:

100%

Feature Branch:
Type of work:
Contributors documentation
Blueprint:
Starter:
Affected tool:

Description

Until today our master branch had "testing" in config/base_branch. This worked for a while but about 10 days ago, branches based on master started failing to build ISO images. An instance of that problem was reported by sajolida.

I've just reset the base branch there to "stable" and I hope it'll fix the problem for doc branches that have current master merged in (so they have my commit).

anonym, can you please:

  1. check that it fixes the problem (I've just merged this updated master branch into doc/9849-sponsor-deliverable-roles and pushed it)
  2. ensure we always reset the base branch to "stable" on the master branch at some well chosen point in the release process

I think this won't happen after a bugfix release, so setting target version to our next major release (3.5).


Related issues

Related to Tails - Bug #14459: Some branches fail to build an ISO because we merge their base branch too late Resolved 08/28/2017
Blocks Tails - Feature #11355: Re-enable Jenkins notifications on ISO build/test failure In Progress 08/28/2017

Associated revisions

Revision 22739984 (diff)
Added by anonym over 1 year ago

Ensure the correct base branch for the master branch.

It should always be stable.

Will-fix: #14857

Revision 4bc45a54 (diff)
Added by intrigeri over 1 year ago

Release process: ensure commands are run in the right directory.

refs: #14857

History

#1 Updated by intrigeri almost 2 years ago

  • Related to Bug #14459: Some branches fail to build an ISO because we merge their base branch too late added

#2 Updated by intrigeri almost 2 years ago

  • Blocks Feature #11355: Re-enable Jenkins notifications on ISO build/test failure added

#3 Updated by anonym over 1 year ago

  • Status changed from Confirmed to Fix committed
  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

ensure we always reset the base branch to "stable" on the master branch at some well chosen point in the release process

I just pushed (to master) 227399841bb183d0f1e19bfcff669902e1010e81 which I think is enough.

#4 Updated by anonym over 1 year ago

  • Status changed from Fix committed to In Progress

#5 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 50 to 70

LGTM, pushed 4bc45a54faaeca67698ffac0214874c869b56f0b on top to make it consistent with the rest of this section (I know it wasn't previously, so your commit did not introduce any regression, but while we're at it we can as well fix such issues :)

#6 Updated by anonym over 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (anonym)
  • % Done changed from 70 to 100
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

LGTM, pushed 4bc45a54faaeca67698ffac0214874c869b56f0b on top to make it consistent with the rest of this section (I know it wasn't previously, so your commit did not introduce any regression, but while we're at it we can as well fix such issues :)

Thanks, that looks better!

Also available in: Atom PDF