Project

General

Profile

Bug #14849

Tails Installer doesn't fit if the vertical screen size is 600

Added by mercedes508 almost 2 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
10/14/2017
Due date:
% Done:

100%

Feature Branch:
bug/14849-vertical-screen-size
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Installer

Description

When using a vertical resolution of 600, the lowest button of Tails Installer (i.e. install or upgrade) are hidden.

Tails Installer should be usable on small screen resolution.

Currently the window opens at 645px height, when no USB key is plugged in.


Related issues

Duplicated by Tails - Bug #15098: Tails Installer is not usable on a 1024x600 resolution Duplicate 12/25/2017

Associated revisions

Revision 48a05f21
Added by intrigeri about 1 year ago

Merge branch 'bugfix/15590-14849-14720-14810-installer-fixes-for-3.9' into devel (Fix-committed: #15590, #14849, #14720, #14810)

History

#1 Updated by intrigeri almost 2 years ago

  • Assignee changed from intrigeri to mercedes508
  • QA Check set to Info Needed

Is it a regression?

If it is, then please reassign to kurono or anonym, who are likely to be responsible for the corresponding change.

If it isn't, then well, this is going to be added to the backlog. I don't think we'll handle this with high priority as there is a way to move the window and click on the button.

#2 Updated by mercedes508 almost 2 years ago

  • Assignee changed from mercedes508 to anonym
  • QA Check changed from Info Needed to Dev Needed

Yes it it, because Tails Installer is different from version 3.1, that's why it doesn't fit anymore.

#3 Updated by intrigeri over 1 year ago

  • Duplicated by Bug #15098: Tails Installer is not usable on a 1024x600 resolution added

#4 Updated by intrigeri over 1 year ago

  • Assignee changed from anonym to kurono
  • QA Check deleted (Dev Needed)

kurono, wanna give it a try? I assume that making some part of the UI (logo, text log area) less high should be enough.

#5 Updated by u over 1 year ago

  • Description updated (diff)

#6 Updated by kurono over 1 year ago

  • Target version set to Tails_3.6

#7 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7

#8 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#9 Updated by kurono over 1 year ago

  • Status changed from Confirmed to In Progress
  • Assignee deleted (kurono)
  • % Done changed from 0 to 10
  • QA Check set to Ready for QA
  • Feature Branch set to bug/14849-vertical-screen-size

intrigeri wrote:

kurono, wanna give it a try? I assume that making some part of the UI (logo, text log area) less high should be enough.

I have reduced the size of the logo and the status textbox so the installer fits in the screen.

#10 Updated by intrigeri about 1 year ago

  • Assignee set to intrigeri
  • Target version changed from Tails_3.8 to Tails_3.9

#11 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to kurono
  • QA Check changed from Ready for QA to Info Needed

Please rebase your work on top of the current upstream master branch, as opposed to the packaging (tails/master) branch.

#12 Updated by kurono about 1 year ago

  • Assignee changed from kurono to intrigeri
  • QA Check changed from Info Needed to Ready for QA

intrigeri wrote:

Please rebase your work on top of the current upstream master branch, as opposed to the packaging (tails/master) branch.

Done.

#13 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 100
  • QA Check changed from Ready for QA to Pass

Great! Merged into master, will be part of the next release of tails-installer.

#14 Updated by intrigeri about 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF