Project

General

Profile

Bug #14832

Feature #12035: Donation campaign 2017

Change Bank account on donation page to CCT

Added by u about 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
Fundraising
Target version:
Start date:
10/11/2017
Due date:
% Done:

0%

Feature Branch:
feature/14832+movetocct
Type of work:
Website
Blueprint:
Starter:
Affected tool:

Description

I've been told this is possible now! yay :)

white.png View (48.5 KB) sajolida, 10/16/2017 07:31 PM

History

#1 Updated by u about 2 years ago

  • Assignee changed from u to sajolida
  • Target version set to Tails_3.3
  • QA Check set to Ready for QA
  • Feature Branch set to 451f:tails/feature/14832+movetocct

Please review!

#2 Updated by u about 2 years ago

I'm redoing some modifications right now. So please hold on until further notice.

#3 Updated by u about 2 years ago

Ok, I've updated the branch.

#4 Updated by intrigeri about 2 years ago

sajolida, I could probably handle this myself if you ask me to.

#6 Updated by u about 2 years ago

  • Priority changed from Normal to Elevated

#7 Updated by sajolida about 2 years ago

  • File white.png View added
  • Assignee changed from sajolida to u
  • QA Check changed from Ready for QA to Dev Needed

I really like the new layout, the background color to structure the page, and the reordering!

Some things that need more work or justification:

  • In your branch history, you're not explaining why you're introducing RiseupLabs as a possible option for wire transfer. I think that we didn't list it last year to make things simplier on Riseup's side: they have a dedicated PayPal account for us but not a dedicated bank account. I might remember incorrectly so I would need more info to justify your change in case you investigate this more... In any case right now you page says that CCT is the account holder of our money in the USA :)
  • I initially called this "bank transfer" (and not "wire transfer") on purpose. "Bank transfer" is correct according to https://en.wikipedia.org/wiki/Wire_transfer and I thought that it would be more understandable to an international audience that might not relate so much to "wire".
  • I think it can be problematic to underline text when it's not a link. For example, jaster commented on this while reviewing the installation assistant, so I'd rather find another graphical emphasis for the different options. I personally think that leaving the font unchanged is fine. I tried bold as well and it works too.
  • I would replace "The Center for Cultivation of Technology [...] Need a donation receipt?." by "Donations are tax-deductible to the full extent permitted by law.": you made the right choice of pointing to CCT's page for the details so the less we put on our page, the better. Bonus point: it takes up one line instead of three :)
  • The image for "How we spend our money" has a white background that now appears on the gray background that you added. I don't think it's super problematic but I'm not sure that's on purpose either...
  • I'll raise an issue about the bank account number on tails-accounting@ but there's something fishy here.

#8 Updated by sajolida about 2 years ago

I don't dare reopening #12075, but I still wanted to let you know what in February 2017 we received a big check from a charitable fund at RiseupLabs. These people seems to have found a way to send their check to RiseupLabs even though their postal address was not on the donation page. But that also means that checks are still a real thing for rich donors in the US. See 9748dc6 in accounting.git if you're curious.

So I would be fine adding the postal address of RiseupLabs on this page as a way of sending US checks.
From our very little experience with that, I guess that the work for RiseupLabs would be way less than if we instruct people in general to send them wire transfers but that the benefit might still be worth it.

#9 Updated by u about 2 years ago

sajolida wrote:

I don't dare reopening #12075, but I still wanted to let you know what in February 2017 we received a big check from a charitable fund at RiseupLabs. These people seems to have found a way to send their check to RiseupLabs even though their postal address was not on the donation page. But that also means that checks are still a real thing for rich donors in the US. See 9748dc6 in accounting.git if you're curious.
So I would be fine adding the postal address of RiseupLabs on this page as a way of sending US checks.

Ok, I was not aware of this. So let's reopen the ticket but I will tackle it separately from the campaign, or as low prio. And I want to ask people from Riseup what they think about this first.

#10 Updated by u about 2 years ago

sajolida wrote:

I really like the new layout, the background color to structure the page, and the reordering!

Thanks for the review! I will tackle your remarks asap.

Some things that need more work or justification:

  • In your branch history, you're not explaining why you're introducing RiseupLabs as a possible option for wire transfer. I think that we didn't list it last year to make things simplier on Riseup's side: they have a dedicated PayPal account for us but not a dedicated bank account. I might remember incorrectly so I would need more info to justify your change in case you investigate this more... In any case right now you page says that CCT is the account holder of our money in the USA :)

This is not RiseupLab's account, it belongs to CCT. That's also why CCT is marked as being the account holder. It's not a mistake, please see their emails on the subject.

I wanted to add this because I think it's nice for people in the US to have another option than Paypal or wiring money in Euros because currency conversion is often costly.

#11 Updated by u about 2 years ago

  • Assignee changed from u to sajolida
  • QA Check changed from Dev Needed to Ready for QA

I've now addressed all other issues.
About the "fishy" bank account, I've verified that it's the correct one, see emails from CCT.

Please reverify and merge.

#12 Updated by sajolida about 2 years ago

  • Assignee changed from sajolida to u
  • Feature Branch changed from 451f:tails/feature/14832+movetocct to feature/14832+movetocct

Oops, sorry I misunderstood your intention regarding CCT's bank account setup and thanks for enlightening me: There are actually 3 valid banking information, our "own bank account", their general European bank account for donations, and their general US bank account for donations. Uff, quite complex indeed.

I felt this needed a bit more structure on the page and I did that in 8febb84911. Maybe that was only confusion for me because I'm deep in our accounting and donors wouldn't notice but I still thought that factorizing and making the labels a bit more explicit wouldn't hurt. The only downside is that I'm breaking your 2x2 grid structure with Flattr but I think it still looks great.

Feel free to disagree with 2611ee673e which is what I was actually proposing in my preview review.

Other than that I think we're done and you can merged this whenever you want (with or without 2611ee673e, I don't care that much).

#13 Updated by u about 2 years ago

  • Status changed from Confirmed to Resolved

thanks a lot for these very nice improvements! merged!

#14 Updated by intrigeri over 1 year ago

  • QA Check deleted (Ready for QA)

Also available in: Atom PDF