Project

General

Profile

Bug #14831

Feature #12035: Donation campaign 2017

Write blogposts for the donation campaign

Added by Anonymous over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Fundraising
Target version:
Start date:
10/11/2017
Due date:
% Done:

100%

Feature Branch:
feature/blogpost_plans2018
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:

Description

1. General call for donation (published on Oct 20th 2017 Friday)
2. What did we promise last year and what did we accomplish? (see news/what_we_accomplished.mdwn -> planned for November 3rd Friday)
3. What are our plans for the future? (see news/our_plans_for_2018.mdwn -> planned for Nov 10th Friday)
4. Reproducible Tails (I wrote this one as part of #12356 -> planned for Nov. 24th Friday)


Related issues

Related to Tails - Feature #12356: Communicate about reproducible builds to users via a blog post Resolved 03/17/2017

History

#1 Updated by Anonymous over 2 years ago

  • Description updated (diff)

#2 Updated by Anonymous over 2 years ago

  • Assignee changed from Anonymous to sajolida

Assigning to sajolida, please proofread & comment on the first post?
If you can't please assign to intrigeri.

#3 Updated by Anonymous over 2 years ago

  • Related to Feature #12356: Communicate about reproducible builds to users via a blog post added

#4 Updated by Anonymous over 2 years ago

  • Description updated (diff)

#6 Updated by sajolida over 2 years ago

  • Assignee changed from sajolida to Anonymous
  • QA Check changed from Ready for QA to Dev Needed
  • Feature Branch changed from 451f:tails/feature/blogpost_donation to tails/feature/blogpost_donation

Cool, I like it!

I pushed a few small fixes in feature/blogpost_donation.

More comments:

  • I recommend activating a spell checker by default in your text editor. In my .vimrc I have set spell spelllang=en_us.
  • "We have made this clear in our Social Contract, [...] we are affirming a commitment to our beliefs." this sentence is a bit long and entangled and could probably be simplified or split in two. But no big deal either...
  • "small success" → I think the donation campaign last year was a big success, or at least we shouldn't make it look small to people :)
  • In "we raised on average 210.000 €" I understand that you took this figure from /news/why_we_need_donations, but:
    • You should update this figure to include 2016 (#14764 is almost ready).
    • In /news/why_we_need_donations I used the amount of money raised because I was talking about sources of income. Here you are using this figure to show that we have a small budget, so a better figure to use would be the total of expenses, and not of the money raised. You can compute that with ledger -f 2014.dat balance --exchange € '^expenses' in accounting.git:ledger.
  • "each of our users" + "estimated user base": we actually have no clue of how many people use Tails, even regularly, which is what I would call our "user base". The only info we have is how many "people" use Tails each day. I know that's hard to formulate but I clearly don't think that 22061 is our "user base". See 63ba864a06 for the formulation I found last year and that passed other people's review.
  • You don't explain what you graph is about, it has no title or legend.

#7 Updated by Anonymous over 2 years ago

sajolida wrote:

Cool, I like it!

Cool! Thanks for the review.

I pushed a few small fixes in feature/blogpost_donation.

Ack!

More comments:

  • I recommend activating a spell checker by default in your text editor. In my .vimrc I have set spell spelllang=en_us.

ack, done

  • "We have made this clear in our Social Contract, [...] we are affirming a commitment to our beliefs." this sentence is a bit long and entangled and could probably be simplified or split in two. But no big deal either...

ack, done

  • "small success" → I think the donation campaign last year was a big success, or at least we shouldn't make it look small to people :)

ack, done

  • In "we raised on average 210.000 €" I understand that you took this figure from /news/why_we_need_donations, but:
    • You should update this figure to include 2016 (#14764 is almost ready).

yep, thanks!

  • In /news/why_we_need_donations I used the amount of money raised because I was talking about sources of income. Here you are using this figure to show that we have a small budget, so a better figure to use would be the total of expenses, and not of the money raised. You can compute that with ledger -f 2014.dat balance --exchange € '^expenses' in accounting.git:ledger.

ack, done. I used a floored average computed from 2015-2017.
Floor: i wrote an amount which was slightly higher than the computed value to have a round number.

  • "each of our users" + "estimated user base": we actually have no clue of how many people use Tails, even regularly, which is what I would call our "user base". The only info we have is how many "people" use Tails each day. I know that's hard to formulate but I clearly don't think that 22061 is our "user base". See 63ba864a06 for the formulation I found last year and that passed other people's review.

I now changed this to tell the exact number of donations which we received.

  • You don't explain what you graph is about, it has no title or legend.

I wrote a sentence there now.

#8 Updated by Anonymous over 2 years ago

  • Assignee changed from Anonymous to sajolida
  • QA Check changed from Dev Needed to Ready for QA

Could you please have another look? I'd like to merge this tomorrow if possible.

#9 Updated by Anonymous over 2 years ago

  • Feature Branch changed from tails/feature/blogpost_donation to 451f:tails/feature/blogpost_donation

#10 Updated by sajolida over 2 years ago

  • Assignee changed from sajolida to Anonymous
  • QA Check changed from Ready for QA to Pass

Perfect!!!

#11 Updated by Anonymous over 2 years ago

I published the first post and tweeted.

#12 Updated by Anonymous over 2 years ago

  • Feature Branch changed from 451f:tails/feature/blogpost_donation to 451f:tails/feature/blogpost_plans2018

Here is a new blogpost to review: 451f:tails/feature/blogpost_plans2018 in news/our_plans_for_2018.mdwn.
I want to publish this one on December 8th 2017.

#13 Updated by Anonymous over 2 years ago

  • QA Check changed from Pass to Ready for QA

#14 Updated by Anonymous over 2 years ago

  • Description updated (diff)

#15 Updated by Anonymous over 2 years ago

The second post to review is here: 451f:tails/feature/blogpost_what_we_accomplished in news/what_we_accomplished.mdwn I want to publish this one on November 24th.

#16 Updated by Anonymous over 2 years ago

  • Feature Branch changed from 451f:tails/feature/blogpost_plans2018 to 451f:tails/feature/blogpost_plans2018 && 451f:tails/feature/blogpost_what_we_accomplished in news/what_we_accomplished.mdwn

#17 Updated by Anonymous over 2 years ago

  • Feature Branch changed from 451f:tails/feature/blogpost_plans2018 && 451f:tails/feature/blogpost_what_we_accomplished in news/what_we_accomplished.mdwn to 451f:tails/feature/blogpost_plans2018 && 451f:tails/feature/blogpost_what_we_accomplished

#18 Updated by Anonymous over 2 years ago

  • Description updated (diff)

#19 Updated by Anonymous over 2 years ago

  • Assignee changed from Anonymous to sajolida

Ok, both branches are ready for review. Can you do that before november 15th?

#20 Updated by sajolida over 2 years ago

  • Assignee changed from sajolida to Anonymous
  • QA Check changed from Ready for QA to Dev Needed
  1. Our plans
  • Last year I linked to tickets and blueprints like we do on /contribute/roadmap because other geeks might want to dig futher if they are curious. This time you added them only half of the time. Why not be consistent and either have them everywhere or not have them at all?
  • I find the references to the time estimates for the features in the first section very wordy. It seems a lot to me to use about 40% of your word count to basically tell if each feature will be released in the first or second half of the year. Maybe you could use "(early 2018)" and "(late 2018)" instead?
  • I would remove the reference to "*Mobile messaging applications*" because it's "only" the investigation part with no promise of results whatsoever, we have no budget for that so most it will be best effort to say the least, and it's also a very hypothetical quest (that's why we only have the 'investigate' part in our roadmap).
  • Wayland is scheduled for 2019 and not for 2018.

Other than that's it looks good and I'm happy it's shorter than last year :)

  1. What we accomplished
  • "What we accomplished" → "What we accomplished in 2017"?
  • "All these items were part of our roadmap for 2017-2018." → What would we loose by removing this sentence?
  • "revamped" → "redesigned" seems a simplier word.
  • HTTPS mirrors were not paid by Mozilla. Reproducible builds were.
  • Web platform for translators seems weird to list this as a non-accomplishement in that post. But that would be a perfect addition to your post about "Our plans".
  • Tails Installer: You seems to have divided the post in two: '1. features' and '2. the rest'. If that's the case, then I'd say that the improvements to Tails Installer fit in the first section, like the improvements to Tails Greeter.
  • I don't see any reuse of the work I already did in the thank you email to donors from last year (sent on 2017-09-12). If you did that on purpose, that's fine, if you didn't look at it, then I suggest you do as you've rewritten some of the achievements that I already described there.
  • Last year, I tried to limit the amount of links on the blog post for the donation campaign, with the idea that we don't want people to navigate too much out of them until they click on the "Donate" button at the bottom of the page. See /news/what_we_do_with_your_money. But I admin that it might not be a very practical idea while talking about achievements...

#21 Updated by Anonymous over 2 years ago

sajolida wrote:

  1. What we accomplished
  • "What we accomplished" → "What we accomplished in 2017"?

ack

  • "All these items were part of our roadmap for 2017-2018." → What would we loose by removing this sentence?

removed

  • "revamped" → "redesigned" seems a simplier word.

changed

  • HTTPS mirrors were not paid by Mozilla. Reproducible builds were.

yes that was a mistake, corrected.

  • Web platform for translators seems weird to list this as a non-accomplishement in that post. But that would be a perfect addition to your post about "Our plans".

removed from this post

  • Tails Installer: You seems to have divided the post in two: '1. features' and '2. the rest'. If that's the case, then I'd say that the improvements to Tails Installer fit in the first section, like the improvements to Tails Greeter.

moved up.

  • I don't see any reuse of the work I already did in the thank you email to donors from last year (sent on 2017-09-12). If you did that on purpose, that's fine, if you didn't look at it, then I suggest you do as you've rewritten some of the achievements that I already described there.

great! i implemented parts of this email and merged it with my text.

  • Last year, I tried to limit the amount of links on the blog post for the donation campaign, with the idea that we don't want people to navigate too much out of them until they click on the "Donate" button at the bottom of the page. See /news/what_we_do_with_your_money. But I admin that it might not be a very practical idea while talking about achievements...

Absolutely. I thought about it but did not know what to delete. However, I now deleted the links to the 7 Tails releases of 2017.

If you'd like to have a last look on this post, I'd be glad. Pushed to my repo.

#22 Updated by Anonymous over 2 years ago

sajolida wrote:

  1. Our plans
  • Last year I linked to tickets and blueprints like we do on /contribute/roadmap because other geeks might want to dig futher if they are curious. This time you added them only half of the time. Why not be consistent and either have them everywhere or not have them at all?

done

  • I find the references to the time estimates for the features in the first section very wordy. It seems a lot to me to use about 40% of your word count to basically tell if each feature will be released in the first or second half of the year. Maybe you could use "(early 2018)" and "(late 2018)" instead?

done

  • I would remove the reference to "*Mobile messaging applications*" because it's "only" the investigation part with no promise of results whatsoever, we have no budget for that so most it will be best effort to say the least, and it's also a very hypothetical quest (that's why we only have the 'investigate' part in our roadmap).

removed

  • Wayland is scheduled for 2019 and not for 2018.

removed

Would you like to review it again?

#23 Updated by Anonymous over 2 years ago

  • Assignee changed from Anonymous to sajolida
  • QA Check changed from Dev Needed to Ready for QA

#24 Updated by Anonymous over 2 years ago

  • Description updated (diff)

Changing the date and order, I plan to publish one of the posts tomorrow, because the next publication seems way too far away.

#25 Updated by Anonymous over 2 years ago

  • Description updated (diff)

rescheduling

#26 Updated by sajolida over 2 years ago

  • Assignee changed from sajolida to Anonymous
  • QA Check changed from Ready for QA to Pass
  • Feature Branch changed from 451f:tails/feature/blogpost_plans2018 && 451f:tails/feature/blogpost_what_we_accomplished to feature/blogpost_plans2018

I pushed some small fixes to feature/blogpost_plans2018 but other than that I think we're good!

#27 Updated by anonym over 2 years ago

  • Target version changed from Tails_3.3 to Tails_3.5

#28 Updated by Anonymous about 2 years ago

I will publish the next post only next friday after all.

#29 Updated by Anonymous about 2 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

published the last post today.

Also available in: Atom PDF