Project

General

Profile

Bug #14796

OpenPGP applet icon is on the left of the clock on Buster

Added by intrigeri over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
10/07/2017
Due date:
% Done:

100%

Feature Branch:
bugfix/14796-topicons-position
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Associated revisions

Revision 75eb8fd2 (diff)
Added by intrigeri over 1 year ago

Display TopIcons systray on the left of the system menu (refs: #14796).

This fixes #14796 (on Buster, it is displayed in the middle of the screen, on
the left of the clock) and an annoying UX problem we have on Stretch: OpenPGP
applet is in the middle of icons that share the exact same (modern, GNOME
Shell-like) behaviour, which is disturbing when opening one of the modern menus
and moving the mouse left/right to the others, because in the middle one icon
won't react as expected, and the nice blue bottom border continuity is broken.

Revision 4a75e3c0 (diff)
Added by intrigeri over 1 year ago

Display TopIcons systray on the left of the system menu (refs: #14796).

This fixes #14796 (on Buster, it is displayed in the middle of the screen, on
the left of the clock) and an annoying UX problem we have on Stretch: OpenPGP
applet is in the middle of icons that share the exact same (modern, GNOME
Shell-like) behaviour, which is disturbing when opening one of the modern menus
and moving the mouse left/right to the others, because in the middle one icon
won't react as expected, and the nice blue bottom border continuity is broken.

Revision 3d8c889d
Added by anonym over 1 year ago

Merge remote-tracking branch 'origin/bugfix/14796-topicons-position' into stable

Fix-committed: #14796

History

#1 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • Target version changed from Tails_4.0 to Tails_3.6
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/14796-topicons-position

Actually, I've just noticed that on Stretch (Tails 3.2) the position is not optimal either: OpenPGP applet is in the middle of icons that share the exact same (modern, GNOME Shell-like) behaviour. The fix I have for Buster fixes this other problem if applied (by hand) on Tails 3.2, so I'll submit it for Tails devel branch.

#2 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

#3 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

#4 Updated by intrigeri over 1 year ago

  • Status changed from Resolved to In Progress
  • % Done changed from 100 to 50

#5 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.5

Maybe this qualifies as a bugfix?

#6 Updated by anonym over 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

Maybe this qualifies as a bugfix?

Otherwise it is a small enough "minor improvement". :) => merged!

#7 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.5 to Tails_3.4

#8 Updated by anonym over 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF