Project

General

Profile

Feature #14624

Document how to migrate persistence to a new USB stick or update the system partitions of an existing device

Added by sajolida almost 2 years ago. Updated about 1 month ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Persistence
Target version:
-
Start date:
09/12/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Installer

Description

We will have to document this if we decide to either:

  • Encourage people to migrate to a larger system partition (after #12705).
  • Change the layout of the USB stick in a way that's incompatible with the previous layout (maybe as part of #11679).

This also relates to backups (#5301).

As part of some research I did for #12706, I drafted what steps it would take to do such a migrate, both:

  • A. To a new USB stick ("I was stuck with a smallish USB stick, now they are cheaper and it's a good time to change.").
  • B. On the same USB stick ("I bought a very big and fancy USB stick for my Tails and want to make the most out of it!").

The copy of the content of the persistence itself could be based on /doc/first_steps/persistence/copy, though it has a few issues and relies on the command line for everybody.

We should advertise A as slightly easier than B (one copy of persistent files instead of two).

  1. Proactive users

These are the steps for people who might have to do this migration outside of a manual upgrade process.

  • A. Buy a new and bigger USB stick
    • 1. Clone old on new
    • 2. Restart on new
    • 3. Configure persistence on new
    • 4. Restart on new
    • 5. Rescue files from old (fix perms on the terminal)
  • B. Extend the system partition on the same USB stick
    • 1. Clone old on intermediary
    • 2. Restart on intermediary
      • Intermediary must have enough space for all persistent data!
    • 3. Configure persistence on intermediary
    • 4. Restart on intermediary
    • 5. Copy files to intermediary
    • 6. Clone intermediary on old
    • 7. Restart on old
    • 8. Configure persistence on old
    • 9. Restart on old
    • 10. Rescue files from intermediary (fix perms on the terminal)
  1. Reactive users

These are the steps for people who might be doing such a migration as part of a manual upgrade. Tails Installer could detect that the destination USB stick has an old layout and advertise the migration during step #6 of /upgrade/tails ("Upgrade by cloning"). Actually, before people do the actual upgrade and replace it with:

  • A. Buy a new and bigger USB stick (the same as for "proactive" actually...)
    • 1. Clone intermediary on new
    • 2. Restart on new
    • 3. Configure persistence on new
    • 4. Restart on new
    • 5. Copy files to new (fix perms on the terminal)
  • B. Extend the system partition on the same USB stick (pretty much the same as for "proactive" starting on step 3)
    • 3. Configure persistence on intermediary
      • Intermediary must have enough space for all persistent data!
    • 4. Restart on intermediary
    • 5. Copy files to intermediary
    • 6. Clone intermediary on old
    • 7. Restart on old
    • 8. Configure persistence on old
    • 9. Restart on old
    • 10. Rescue files from intermediary (fix perms on the terminal)

I don't think it's realistic to have detailed instructions for all this but it would be good to explain the workflow of each scenario. To make things a bit simpler we could try to have both the "proactive" and "reactive" scenarios on a single page ("/upgrade/system_partition"? "/upgrade/migrate"?) and point /upgrade/tails to them.

We should also take into account what people doing /upgrade/clone would experience.


Related issues

Related to Tails - Feature #5301: Clone or backup system for the persistent volume Confirmed 01/27/2015
Related to Tails - Feature #12706: Adjust the documentation wrt. updated system partition size Resolved 06/15/2017
Related to Tails - Feature #11679: Rethink the installation process and upgrade process Resolved 08/20/2016
Related to Tails - Feature #12214: Document a way to manually backup persistent data Needs Validation 02/06/2017
Related to Tails - Feature #15292: Distribute a USB image Resolved 04/14/2016 01/29/2019
Duplicates Tails - Feature #14605: Improve documentation on "Manually copying your persistent data to a new USB stick" Confirmed 09/05/2017
Blocks Tails - Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing Confirmed 09/11/2018

History

#1 Updated by sajolida almost 2 years ago

  • Tracker changed from Bug to Feature

#2 Updated by sajolida almost 2 years ago

  • Related to Feature #5301: Clone or backup system for the persistent volume added

#3 Updated by sajolida almost 2 years ago

  • Related to Feature #12706: Adjust the documentation wrt. updated system partition size added

#4 Updated by sajolida almost 2 years ago

  • Related to Feature #11679: Rethink the installation process and upgrade process added

#5 Updated by sajolida almost 2 years ago

  • Related to Feature #14605: Improve documentation on "Manually copying your persistent data to a new USB stick" added

#6 Updated by sajolida almost 2 years ago

  • Related to Feature #12214: Document a way to manually backup persistent data added

#7 Updated by intrigeri over 1 year ago

#8 Updated by sajolida 12 months ago

  • Category changed from Installation to Persistence
  • Assignee set to cbrownstein

Also part of "Persistent storage vs Backups".

#9 Updated by sajolida 12 months ago

  • Blocks Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing added

#10 Updated by sajolida 12 months ago

  • Assignee changed from cbrownstein to sajolida
  • Target version set to Tails_3.9

Cody: if you don't mind I'll take over this problem space for some time since I've been working on #15685 lately.

#11 Updated by sajolida 11 months ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

#12 Updated by sajolida 10 months ago

  • Blocks deleted (Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing)

#13 Updated by sajolida 10 months ago

  • Blocks Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing added

#14 Updated by sajolida 9 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#15 Updated by sajolida 7 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#16 Updated by sajolida 6 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#17 Updated by sajolida 4 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#18 Updated by sajolida 2 months ago

  • Target version deleted (Tails_3.14)

#19 Updated by sajolida about 1 month ago

  • Status changed from Confirmed to Duplicate
  • Assignee deleted (sajolida)

I think that all this will be solved by the new doc on #14605.

#20 Updated by sajolida about 1 month ago

  • Related to deleted (Feature #14605: Improve documentation on "Manually copying your persistent data to a new USB stick")

#21 Updated by sajolida about 1 month ago

  • Duplicates Feature #14605: Improve documentation on "Manually copying your persistent data to a new USB stick" added

Also available in: Atom PDF