Project

General

Profile

Feature #14597

Feature #14568: Additional Software Packages

Review automated tests for Additional Software GUI

Added by u over 1 year ago. Updated 8 months ago.

Status:
Rejected
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
09/04/2017
Due date:
04/01/2018
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

This needs to happen before April 15th 2018. BETA release is planned for May 1st 2018. (Tails 3.6) (B3)


Related issues

Blocked by Tails - Bug #15799: "Additional software packages are installed even without network" test always fail in my environment Resolved 08/17/2018

History

#1 Updated by u over 1 year ago

  • Description updated (diff)

#3 Updated by u over 1 year ago

  • Status changed from New to Confirmed

#4 Updated by u over 1 year ago

  • Blocked by Feature #14596: Write automated tests for Additional Software GUI added

#5 Updated by u over 1 year ago

  • Description updated (diff)
  • Target version changed from 2018 to Tails_3.7

#6 Updated by intrigeri about 1 year ago

  • Priority changed from Normal to Elevated

#7 Updated by bertagaz about 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#8 Updated by intrigeri 12 months ago

  • Target version changed from Tails_3.8 to Tails_3.9

#10 Updated by intrigeri 11 months ago

  • Assignee changed from anonym to intrigeri

#13 Updated by intrigeri 10 months ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

I need to schedule this work: I'm super busy until the end of the contract so I need to block time for this. I'll do a first round of review on September 10-12 and then I'll come back to it on October 8-9 after bertagaz has fixed the issues raised by my first review (if any).

But this blocked by #14596 which is 5 months behind schedule and has not been updated since 4 months, so I'll raise the priority of #14596 to express my needs.

#14 Updated by intrigeri 9 months ago

  • Blocked by Bug #15799: "Additional software packages are installed even without network" test always fail in my environment added

#16 Updated by intrigeri 9 months ago

After discussing the scheduling of this ticket with our team lead, I'm hereby postponing my 2 rounds of review to:

  • October 16-17: first round of review
  • November 5-6: second round of review, hopefully leading to a successful validation of the issues raised in the first round

The goal is to have this merged by November 15 so that it makes it into 3.11.

#17 Updated by bertagaz 9 months ago

intrigeri wrote:

After discussing the scheduling of this ticket with our team lead, I'm hereby postponing my 2 rounds of review to:

  • October 16-17: first round of review
  • November 5-6: second round of review, hopefully leading to a successful validation of the issues raised in the first round

The goal is to have this merged by November 15 so that it makes it into 3.11.

As you wish. The deadline was clear so I intended to make it ready for September 10, but review can wait I guess.

#18 Updated by intrigeri 8 months ago

  • Blocked by deleted (Feature #14596: Write automated tests for Additional Software GUI)

#19 Updated by intrigeri 8 months ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100

This ticket does not help me organize my work (quite the opposite). Let's please use "Ready for QA" on tickets that are, well, ready for QA, as we do almost everywhere else.

Also available in: Atom PDF