Project

General

Profile

Feature #14559

Have a permanent incentive to donate on /home

Added by u about 2 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Fundraising
Target version:
Start date:
08/30/2017
Due date:
% Done:

0%

Feature Branch:
web/14559-permanent-incentive
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

People relying on Tails should be our first supporters.

Right now we have a donate button on all the pages of the website, but in #7176 we were also considering targeting specifically Tails users.

Putting something on top of /home with a bit more text than that donate button to act as a stronger incentive for Tails users to donate might be a great way of having more sustained donations throughout the year.

See also: https://mailman.boum.org/pipermail/tails-project/2017-August/000932.html

signature.asc (866 Bytes) sajolida, 09/03/2017 09:42 AM

matomo.png View (40.5 KB) sajolida, 06/03/2018 05:01 PM

screen.png View - missing svg (129 KB) u, 05/06/2019 05:32 PM


Related issues

Related to Tails - Feature #15866: Design, validate & implement an incentive to contribute in Tails Confirmed 08/30/2018

History

#1 Updated by intrigeri about 2 years ago

  • Status changed from New to Confirmed

#2 Updated by sajolida about 2 years ago

Note that this is about https://tails.boum.org/home (the homepage of Tor
Browser in Tails) and not https://tails.boum.org/ (the root of our website).

#3 Updated by sajolida about 2 years ago

  • Subject changed from Think about What can we leave on the homepage once the donation campaign is over to Have a permanent incentive to donate on /home

Renaming this ticket a bit.

I think this doesn't have to be done as part of the donation campaign. But it would be good to have it ready, for example, when the campaign ends to leave something visible for Tails users.

I also think that this is a first and easy step towards #7176, so I'll close it.

#4 Updated by sajolida about 2 years ago

  • Description updated (diff)

#6 Updated by u over 1 year ago

  • Target version changed from 2018 to Tails_3.6

#7 Updated by u over 1 year ago

  • Assignee changed from u to sajolida

I'd like to give this one to you, sajolida. What do you think?

#8 Updated by sajolida over 1 year ago

Fine with me!

I don't know when I'll be able to work on it but I'd like to.

#9 Updated by sajolida over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.9

We're out of budget until April.

#10 Updated by sajolida over 1 year ago

  • Parent task deleted (#12035)

#11 Updated by sajolida over 1 year ago

Here is what Matomo has :)

#12 Updated by u over 1 year ago

sajolida wrote:

Here is what Matomo has :)

A bit too much text and too restless IMO, but I like the idea. I think we should aim at something similar but much simpler.

#13 Updated by sajolida about 1 year ago

  • Assignee changed from sajolida to u
  • QA Check set to Info Needed

Would you be interested in coming up with your own version of this incentive?

I thought about trying to have two versions and see which ones work better (as some kind of very primitive A/B test).

If so, when do you think you could work on that?

#14 Updated by u about 1 year ago

  • Related to Feature #15866: Design, validate & implement an incentive to contribute in Tails added

#15 Updated by sajolida about 1 year ago

  • Assignee changed from u to sajolida
  • Target version changed from Tails_3.9 to Tails_3.10.1

#16 Updated by sajolida 11 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.12
  • QA Check changed from Info Needed to Dev Needed

Let's try to have this ready once the donation campaign is over → 3.12.

#17 Updated by sajolida 8 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#18 Updated by sajolida 8 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#19 Updated by sajolida 6 months ago

  • QA Check changed from Dev Needed to Ready for QA

I sent a proposal to tails-project.

After we reach an agreement on tails-project, I'll assign it to someone else for the code review.

#20 Updated by sajolida 5 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from sajolida to u
  • Feature Branch set to web/14559-permanent-incentive

#21 Updated by u 5 months ago

  • Assignee changed from u to sajolida
  • QA Check changed from Ready for QA to Dev Needed

Nice work. But but but

- the svg is missing, did you commit and push? (see screenshot)
- I think the underlining is nice, but unfortunately it makes things harder to read, so UX-wise it seems like a no-go in this box (also because the underline spans over 3 lines). Can you imagine something different there? I have no idea right away, but I'm happy to think about it if you want me to.

#22 Updated by u 5 months ago

#23 Updated by sajolida 5 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Dev Needed)

- the svg is missing, did you commit and push? (see screenshot)

Good catch. I added it now in f2d2d1268c.

- I think the underlining is nice, but unfortunately it makes things harder to read, so UX-wise it seems like a no-go in this box (also because the underline spans over 3 lines).

I got tired of defending my underlining and got rid of it again in e6f7df8bb1.

It's live now. Thanks for the prompt review!

Also available in: Atom PDF