Project

General

Profile

Feature #14469

Feature #14468: Add VeraCrypt support to Tails

Write Gherkin scenarios for VeraCrypt automated tests

Added by segfault over 2 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
08/28/2017
Due date:
% Done:

100%

Feature Branch:
test/14471-veracrypt
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

This is the initial part of "A.3 Write automated tests". Actual steps will be implemented in #14470, #14471 and #14472.

For potential scenario candidates, see:


Related issues

Blocked by Tails - Feature #14742: VeraCrypt: UX & GUI design sprint Resolved 09/29/2017
Blocks Tails - Feature #14471: Write tests for VeraCrypt support in GNOME Disks Resolved 08/28/2017

Associated revisions

Revision 870b785c (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite (USB drive): write Gherkin for test scenarios (refs: #14469).

Note that we can't use Scenario Outlines yet (see #10328 for details),
hence the — arguably ugly — code duplication.

Revision 33218134 (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite (USB drive): tag scenarios (refs: #14469).

Revision 6fc7a2a3 (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite: simplify Gherkin (refs: #14469).

Revision 0bc618b4 (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite (file container): add second scenario (refs: #14469, #15239).

Revision bc4f26d4 (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite (file container): write the remaining scenarios (refs: #14469, #15239).

Revision 194a7d8b (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite: group scenarios by software being used (refs: #14469).

Revision 99bbad37 (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite: add another scenario (refs: #14469, #15238).

Revision e517a1a1 (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite: remove scenario tags (refs: #14469)

They were useful for the initial development but I don't use them
anymore so let's make the Gherkin and test suite output lighter.

History

#1 Updated by intrigeri over 2 years ago

  • Subject changed from Write Gherkin scenarios to Write Gherkin scenarios for VeraCrypt automated tests
  • Category set to Test suite

#2 Updated by intrigeri about 2 years ago

#3 Updated by intrigeri about 2 years ago

  • Description updated (diff)

#4 Updated by intrigeri about 2 years ago

  • Blocks Feature #14470: Write tests for VeraCrypt support in udisks added

#5 Updated by intrigeri about 2 years ago

  • Blocks Feature #14471: Write tests for VeraCrypt support in GNOME Disks added

#6 Updated by intrigeri about 2 years ago

  • Blocks Feature #14472: Write tests for VeraCrypt support in GNOME Files added

#7 Updated by anonym almost 2 years ago

  • Target version changed from Tails_3.5 to Tails_3.6

#8 Updated by anonym almost 2 years ago

  • Blocks deleted (Feature #14470: Write tests for VeraCrypt support in udisks)

#9 Updated by anonym almost 2 years ago

  • Blocks deleted (Feature #14472: Write tests for VeraCrypt support in GNOME Files)

#10 Updated by anonym almost 2 years ago

  • Blocks deleted (Feature #14471: Write tests for VeraCrypt support in GNOME Disks)

#11 Updated by anonym almost 2 years ago

  • Blocks Feature #14471: Write tests for VeraCrypt support in GNOME Disks added

#12 Updated by anonym almost 2 years ago

  • Blocks Feature #14472: Write tests for VeraCrypt support in GNOME Files added

#13 Updated by intrigeri almost 2 years ago

This can now be done for the GNOME Disks tests (#14471). anonym will work on this during the 3.6 freeze.

#14 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7

#15 Updated by intrigeri over 1 year ago

  • Priority changed from Normal to Elevated

#16 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#17 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#19 Updated by intrigeri over 1 year ago

  • Assignee changed from anonym to intrigeri
  • Target version changed from Tails_3.9 to Tails_3.10.1

#21 Updated by intrigeri about 1 year ago

  • Feature Branch set to test/14471-veracrypt

#22 Updated by intrigeri about 1 year ago

  • Description updated (diff)

#23 Updated by intrigeri about 1 year ago

  • Description updated (diff)

#24 Updated by intrigeri about 1 year ago

  • % Done changed from 0 to 10

#25 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to In Progress

#26 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to segfault
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

Gherkin written (and field-tested by actually implementing the scenarios). Interestingly, there was no budget allocated to review the VeraCrypt test suite work, not sure how it was supposed to be handled. Anyway, I figure you're the best placed person to check whether what I'm testing makes sense, has good enough coverage (see #14472#note-10), and is understandable. So please clock this review separately, as part of the "test suite maintenance" core budget.

Note that here I'm only asking for a review of the Gherkin i.e. the features/veracrypt.feature file and nothing more. I'll ask kibi to review the rest of my work once it's ready.

#27 Updated by intrigeri about 1 year ago

  • Blocks deleted (Feature #14472: Write tests for VeraCrypt support in GNOME Files)

#28 Updated by segfault about 1 year ago

  • Assignee changed from segfault to intrigeri
  • QA Check changed from Ready for QA to Pass

Whoops, didn't have this one on my radar. I took a look and the existing scenarios look good. I noticed that there are none for unlocking via GNOME Files (i.e. clicking on the entry in the places sidebar). I just read on #14472 that that's because you ran out of budget, so OK, the existing tests will have to do.

#29 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100

Thanks!

Also available in: Atom PDF