Project

General

Profile

Feature #14448

Consider documenting Rufus as a workaround in case UUI doesn't work

Added by sajolida about 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
-
Start date:
08/24/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Installation Assistant

Related issues

Related to Tails - Bug #13206: Install by cloning sometimes silently fails from a stick installed with UUI Rejected 09/29/2017
Related to Tails - Feature #11825: Consider switching to Rufus instead of UUI for Windows users Rejected 09/22/2016
Related to Tails - Bug #12146: Tails installed using dd is not seen as a bootable device on MacBook Pro Resolved 12/08/2017
Blocked by Tails - Feature #10984: Test Rufus Rejected 01/22/2016

History

#1 Updated by sajolida about 2 years ago

#2 Updated by intrigeri about 2 years ago

  • Status changed from New to Confirmed

#3 Updated by sajolida about 2 years ago

  • Related to Bug #13206: Install by cloning sometimes silently fails from a stick installed with UUI added

#4 Updated by sajolida about 2 years ago

  • Related to Feature #11825: Consider switching to Rufus instead of UUI for Windows users added

#5 Updated by emmapeel over 1 year ago

  • Blocks Feature #14758: Core work 2017Q4 → 2018Q1: Technical writing added

#6 Updated by sajolida over 1 year ago

  • Blocks deleted (Feature #14758: Core work 2017Q4 → 2018Q1: Technical writing)

#7 Updated by sajolida over 1 year ago

  • Related to Bug #12146: Tails installed using dd is not seen as a bootable device on MacBook Pro added

#8 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to Rejected

We tested Rufus during our sprint on installation and upgrade.

The interface is quite complex and probably even more error prone than UUI.

Installing works if the "dd mode" is chosen and then it does a pure dd copy.

Such a copy won't work on maybe UEFI (for example my MacBook Pro) while UUI does (#12146).

We have plans to solve this for real with https://tails.boum.org/blueprint/usb_install_and_upgrade/usb_bootable_disk_image/.

So honestly, I don't think it's a good investment to document Rufus as an alternative to UUI since it's going to be relevant only in some cases, probably when people didn't follow the UUI instructions correctly (#13206). And I'm rejecting this.

I'd be happy to merge even a very rough documentation if help desk finds this helpful but I won't write it myself.

I'd be happy to raise again the importance of this ticket if provided with a reproducible way of seeing UUI fails on a compute and Rufus work. I don't remember have heard this yet.

In the meantime, I'll try to move forward #13206 which seems smaller and with clearer benefits.

#9 Updated by sajolida over 1 year ago

I also considered pointing to the Ubuntu instructions for Rufus instead of write ours:

https://tutorials.ubuntu.com/tutorial/tutorial-create-a-usb-stick-on-windows#3

They was people to choose between "MBR partition scheme for UEFI" and "MBR Partition Scheme for BIOS or UEFI". But I don't think that we can rely on people knowing whether their computer is UEFI or BIOS so that won't work either.

Also available in: Atom PDF