Project

General

Profile

Feature #14447

Consider using Win32 Disk Imager to install from Windows

Added by anonym about 2 years ago. Updated 3 months ago.

Status:
In Progress
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
-
Start date:
08/24/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

Description

https://sourceforge.net/projects/win32diskimager/

It's a dd for Windows with a simple GUI. In other words, it should keep working as long as our dd instructions work.

Win32 Disk Imager.png View (48.3 KB) sajolida, 02/04/2018 05:07 PM


Related issues

Related to Tails - Feature #10984: Test Rufus Rejected 01/22/2016
Related to Tails - Bug #11348: Test Etcher, a multiplatform USB stick burner Resolved 04/14/2016
Related to Tails - Bug #13206: Install by cloning sometimes silently fails from a stick installed with UUI Rejected 09/29/2017
Related to Tails - Bug #14959: Test UEFI boot with a Tails installed with UUI Resolved 11/11/2017
Related to Tails - Feature #16381: Investigate the outgoing network connections of Etcher In Progress 01/21/2019
Related to Tails - Feature #16553: Consider using Rawrite32 to install from Windows In Progress 03/13/2019
Blocks Tails - Feature #16688: Core work 2019Q3 → 2019Q4: User experience Confirmed

History

#1 Updated by sajolida about 2 years ago

#2 Updated by sajolida about 2 years ago

  • Related to Bug #11348: Test Etcher, a multiplatform USB stick burner added

#3 Updated by intrigeri about 2 years ago

Does UUI work for UEFI boot? If it does, then this proposal brings a serious regression.

#4 Updated by anonym about 2 years ago

  • Status changed from New to Confirmed

intrigeri wrote:

Does UUI work for UEFI boot? If it does, then this proposal brings a serious regression.

For the record, dd-type installation doesn't work with UEFI in our automated test suite. I verified with:

  Scenario: bla
    Given a computer
    And the computer is set to boot in UEFI mode
    Given I temporarily create a 4 GiB disk named "isohybrid" 
    And I write the Tails ISO image to disk "isohybrid" 
    When I start Tails from USB drive "isohybrid" with network unplugged and I login

(last step fails at UEFI boot menu)

#5 Updated by sajolida about 2 years ago

  • Assignee changed from sajolida to anonym

I don't have access to a UEFI computer so I cannot test UUI on UEFI.

anonym: Can you do that?

#6 Updated by intrigeri about 2 years ago

  • Target version changed from Tails_3.2 to Tails_3.5

#7 Updated by sajolida about 2 years ago

  • Related to Bug #13206: Install by cloning sometimes silently fails from a stick installed with UUI added

#8 Updated by intrigeri about 2 years ago

  • Related to Bug #14959: Test UEFI boot with a Tails installed with UUI added

#9 Updated by intrigeri about 2 years ago

  • Assignee changed from anonym to sajolida

sajolida wrote:

I don't have access to a UEFI computer so I cannot test UUI on UEFI.

anonym: Can you do that?

Moved this to #14959: it's somewhat off-topic here, and it makes little sense to me to block on this test before sajolida can make progress here.

#10 Updated by anonym almost 2 years ago

  • Target version changed from Tails_3.5 to Tails_3.6

#12 Updated by sajolida almost 2 years ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (sajolida)

Tested on https://tails.boum.org/blueprint/usb_install_and_upgrade/usb_bootable_disk_image/#win32-disk-imager.

I'm rejecting this ticket because:

  • Win32 is extremelly slow and has other UX glitches.
  • ISO images installed using dd (or similar tools) fail to boot on UEFI while UUI works on some (despite having an MBR partition table).

So switching from UUI to Win32 Disk Images would be at least a regression on quite a few UEFI laptops.

#13 Updated by sajolida 8 months ago

  • Subject changed from Replace UUI with Win32 Disk Imager to Consider using Win32 Disk Imager to install from Windows
  • Status changed from Rejected to Confirmed
  • Target version changed from Tails_3.6 to Tails_3.14

Now that we are distributing USB images, the UEFI problem should be solved. After seeing #16381, I think it's worth testing Win32 Disk Imager again.

#14 Updated by sajolida 8 months ago

  • Blocks Feature #16080: Core work 2018Q4 → 2019Q2: User experience added

#15 Updated by sajolida 8 months ago

  • Related to Feature #16381: Investigate the outgoing network connections of Etcher added

#16 Updated by intrigeri 7 months ago

  • Assignee set to sajolida

Given the metadata you've set last month, I guess you meant to assign this to you :)

#17 Updated by CyrilBrulebois 6 months ago

  • Target version changed from Tails_3.14 to Tails_3.15

#18 Updated by sajolida 6 months ago

  • Blocks deleted (Feature #16080: Core work 2018Q4 → 2019Q2: User experience)

#19 Updated by sajolida 6 months ago

  • Blocks Feature #16688: Core work 2019Q3 → 2019Q4: User experience added

#20 Updated by sajolida 6 months ago

  • Target version changed from Tails_3.15 to Tails_3.16

#21 Updated by sajolida 4 months ago

  • Status changed from Confirmed to In Progress
  • Type of work changed from Research to Discuss

Done!

It has seen 5 releases in 6 years and the last one was in March 2017. The previous one was in March 2014. So very little energy is put into it and I'm not sure that it qualifies as being maintained.

In terms of UX, it's pretty simple but I'm worried about the following glitches:

  1. It has no portable version. You have to go through an installer and put it in your menus, etc. On top of the annoyance, I wonder whether this brings in more limitation on which Windows system it can be used on.
  2. It takes into account USB sticks plugged in after starting (Rawrite32 doesn't do that).
  3. Download is 12M vs 76M for Etcher and 2.2M for Rawrite32.
  4. Writing time is 5m17s which is good.
  5. It doesn't do a verification pass like Etcher does.
  6. The USB stick boots fine but I'm not sure how to check the integrity of the data (doing sha512sum on the device or the partition doesn't seem to work but maybe I did something wrong).

So Win32 Disk Imager could be a good alternative to Etcher. It's a shame that it requires an installer and it's less maintained than Rawrite32.

#22 Updated by sajolida 4 months ago

  • Related to Feature #16553: Consider using Rawrite32 to install from Windows added

#23 Updated by sajolida 3 months ago

  • Assignee deleted (sajolida)
  • Target version deleted (Tails_3.16)

I did my part as UX team.

Also available in: Atom PDF