Project

General

Profile

Bug #13480

The Vagrant VM has too little memory for disk builds

Added by intrigeri over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
07/17/2017
Due date:
% Done:

100%

Feature Branch:
bugfix/13480-bump-build-VM-memory
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

As discovered on #12741:


Related issues

Blocks Tails - Bug #12741: /lib/modules/*/modules.* not reproducible in some environments Resolved 06/19/2017

Associated revisions

Revision c866156f (diff)
Added by bertagaz over 2 years ago

Update memory requirement for builds.

Refs: #13480

Revision de14ab1c
Added by bertagaz over 2 years ago

Merge remote-tracking branch 'origin/bugfix/13480-bump-build-VM-memory' into stable

Fix-committed: #13480

Revision 084f057f (diff)
Added by bertagaz over 2 years ago

Lower BUILD_SPACE_REQUIREMENT by 256M. (refs: #13480)

We've raised the required memory for on-disk build, so let's lower this
so that we can keep on building in RAM with the same amount of memory
than before the bump and don't need to allocate more memory to our
isobuilders.

Revision 0e25fbf8
Added by bertagaz over 2 years ago

Merge remote-tracking branch 'origin/bugfix/13480-bump-build-VM-memory' into stable

Fix-committed: #13480

History

#1 Updated by intrigeri over 2 years ago

  • Blocks Bug #12741: /lib/modules/*/modules.* not reproducible in some environments added

#2 Updated by bertagaz over 2 years ago

  • % Done changed from 50 to 60
  • Feature Branch set to bugfix/13480-bump-build-VM-memory

Pushed to the new related branch in tails.git to see if it means we have to bump the lizard isobuilders memory.

#3 Updated by bertagaz over 2 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (bertagaz)
  • % Done changed from 60 to 100
  • QA Check changed from Ready for QA to Pass

bertagaz wrote:

Pushed to the new related branch in tails.git to see if it means we have to bump the lizard isobuilders memory.

Indeed had to bump isobuilders ram with 256M. Works fine now, so merged into stable and devel.

#4 Updated by intrigeri over 2 years ago

  • Status changed from 11 to In Progress
  • Assignee set to bertagaz
  • QA Check changed from Pass to Info Needed

bertagaz wrote:

Pushed to the new related branch in tails.git to see if it means we have to bump the lizard isobuilders memory.

Indeed had to bump isobuilders ram with 256M. Works fine now, so merged into stable and devel.

Wait, why would isobuilders need more RAM due to an increase of the memory for disk builds? Don't they build in RAM?

We do VM_MEMORY_FOR_RAM_BUILDS = VM_MEMORY_FOR_DISK_BUILDS + BUILD_SPACE_REQUIREMENT, and the previous values worked fine, which means that we can decrease BUILD_SPACE_REQUIREMENT so that VM_MEMORY_FOR_RAM_BUILDS remains the same as it was, no?

#5 Updated by bertagaz over 2 years ago

  • Status changed from In Progress to 11

#6 Updated by intrigeri over 2 years ago

  • Status changed from 11 to In Progress
  • % Done changed from 100 to 80

(As said above I think the fix is wrong, in the sense it has problematic side-effects that don't make sense to me.)

#7 Updated by bertagaz over 2 years ago

  • Assignee changed from bertagaz to intrigeri

intrigeri wrote:

bertagaz wrote:

Pushed to the new related branch in tails.git to see if it means we have to bump the lizard isobuilders memory.

Indeed had to bump isobuilders ram with 256M. Works fine now, so merged into stable and devel.

Wait, why would isobuilders need more RAM due to an increase of the memory for disk builds? Don't they build in RAM?

We do VM_MEMORY_FOR_RAM_BUILDS = VM_MEMORY_FOR_DISK_BUILDS + BUILD_SPACE_REQUIREMENT, and the previous values worked fine, which means that we can decrease BUILD_SPACE_REQUIREMENT so that VM_MEMORY_FOR_RAM_BUILDS remains the same as it was, no?

True, I did not think to lower BUILD_SPACE_REQUIREMENT. I've pushed a commit doing that on top of the branch, does it looks good to you? If so, I'll set back the memory of our isobuilders to where it was.

#8 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to bertagaz
  • QA Check changed from Info Needed to Dev Needed

I've pushed a commit doing that on top of the branch, does it looks good to you?

I think you got the maths wrong: (12.5 - 12.3) * 1024 = 204.8 != 256.

I think you instead want (12.5 - 12.25) * 1024 = 256.

With this fixed + the commit message clarified ("from 256M" is wrong, I think you rather mean something like "by 256M") i.e. rewriting history, feel free to merge directly into stable and devel :)

#9 Updated by bertagaz over 2 years ago

  • Status changed from In Progress to 11
  • % Done changed from 80 to 100

#10 Updated by bertagaz over 2 years ago

  • Assignee deleted (bertagaz)
  • QA Check changed from Dev Needed to Pass

Also lowered the memory of our isobuilders to their initial amount before this branch, and the builds in Jenkins still work, so case closed I guess.

#11 Updated by bertagaz over 2 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF