Project

General

Profile

Bug #13469

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

Starting applications "via GNOME Activities Overview" step is fragile

Added by bertagaz over 2 years ago. Updated 3 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
07/14/2017
Due date:
% Done:

100%

Feature Branch:
https://salsa.debian.org/tails-team/tails/merge_requests/37#note_108671
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Test suite fails with:

FindFailed: can not find GnomeActivitiesOverview.png

Happened 14 times in June 2017, 21 for what logs we have.

It does open the Gnome applications menu though, as shown by the screenshot.

Maybe the SUPER key press is lost, or we have to bump a bit the waiting time for the Gnome activities overview panel to be displayed?

02_07_37_Adding_a_certificate_to_Pidgin.png View (35.8 KB) bertagaz, 07/14/2017 10:14 AM


Related issues

Related to Tails - Feature #12289: Deal with June 2017 false positive scenarios Resolved 06/05/2017 07/05/2017
Related to Tails - Bug #11401: robust_notification_wait sometimes opens the Applications menu which breaks tests Resolved 05/05/2016
Related to Tails - Feature #12652: Improve the 'I start ... via GNOME Activities Overview' step Confirmed 06/07/2017

Associated revisions

Revision a1d045bd (diff)
Added by intrigeri about 1 year ago

Test suite: make starting apps via GNOME Activities Overview more robust (refs: #13469).

Revision 91e5a5f9 (diff)
Added by intrigeri 3 months ago

Test suite: make starting apps via the GNOME Activities Overview more robust (refs: #13469).

Revision 97a01a22 (diff)
Added by intrigeri 3 months ago

Test suite: remove fragile tag (refs: #13469)

It might be that this scenario is fragile for other, undocumented reasons
than #13469. To learn about this, we need to run it and see what happens.
Only then will we be able to document the other reasons why this scenario
is fragile, if any.

Revision e8895194
Added by segfault 3 months ago

Merge branch 'test/17029+17027+17028+16931+force-all-tests' into devel

Closes: #17029, #17027, #17028, #16931, #16617, #17030, #10708, #16465
Closes: #13469

History

#1 Updated by bertagaz over 2 years ago

  • Related to Feature #12289: Deal with June 2017 false positive scenarios added

#2 Updated by bertagaz over 2 years ago

  • Priority changed from Normal to Elevated

Bumping priority, it's concerning all scenarios.

#3 Updated by intrigeri over 2 years ago

  • Assignee set to bertagaz
  • QA Check set to Info Needed

bertagaz wrote:

It does open the Gnome applications menu though, as shown by the screenshot.

And that's precisely why the Overview does not open: the SUPER key is ignored when the Applications menu is open.

Maybe the SUPER key press is lost, or we have to bump a bit the waiting time for the Gnome activities overview panel to be displayed?

… so I believe neither of these will work.

Last time we had a similar issue (#11401), it was caused by one of our hacks that clicked in the wrong place and opened the Applications menu as a result. I suspect it's the same here. Can you please attach the debug log and video?

#4 Updated by intrigeri over 2 years ago

  • Related to Bug #11401: robust_notification_wait sometimes opens the Applications menu which breaks tests added

#5 Updated by intrigeri about 1 year ago

  • Assignee deleted (bertagaz)
  • QA Check deleted (Info Needed)

I've noticed another source of fragility here: sometimes the Overview opens just fine, we type our query (in my case, "Disks") but there's no search results. Looking at the Journal, I notice that starting to type a search query in the Overview triggers the startup of a number of DBus services (org.gnome.ControlCenter.SearchProvider, org.gnome.Nautilus, org.gnome.Calculator.SearchProvider, org.gnome.seahorse.Application). It looks like there's a bug in GNOME Shell here.

Can you please attach the debug log and video?

One year later, I'm giving up.

#6 Updated by intrigeri about 1 year ago

intrigeri wrote:

I've noticed another source of fragility here: sometimes the Overview opens just fine, we type our query (in my case, "Disks") but there's no search results. Looking at the Journal, I notice that starting to type a search query in the Overview triggers the startup of a number of DBus services (org.gnome.ControlCenter.SearchProvider, org.gnome.Nautilus, org.gnome.Calculator.SearchProvider, org.gnome.seahorse.Application). It looks like there's a bug in GNOME Shell here.

I've implemented a workaround for this problem (a1d045bd167e47d620d6c2b22259bf6a946e9a21) and it seems to work so far.
But that does not address the other robustness issue that bertagaz has reported here.

#7 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to In Progress

#8 Updated by intrigeri 9 months ago

  • Status changed from In Progress to Confirmed

#9 Updated by intrigeri 3 months ago

  • Assignee set to intrigeri

The recent failures here look like this:

03:46:37.768579404: executing Python as amnesia: node534 = node533.child('No Notifications', roleName='label')
03:46:41.843246621: execution complete
03:46:41.843435077: executing Python as amnesia: node535 = node533.child('No Notifications', roleName='label')
03:46:45.525478217: execution complete
03:46:45.568328359: [log]  TYPE "#ESC." 
    And all notifications have disappeared                                                                                              # features/step_definitions/common_steps.rb:441
03:46:45.570811783: Sikuli: calling wait("GnomeApplicationsMenu.png")...
03:46:45.628754688: Remote shell: calling as amnesia: xdotool key Super
03:46:46.126956051: call returned: [0, "", ""]
03:46:46.127133834: Sikuli: calling wait("GnomeActivitiesOverview.png")...
03:47:12.730567115: Failed to find fuzzy candidate picture for GnomeActivitiesOverview.png
03:47:12.730779237: FindFailedHookFailure was raised, re-running the failing Sikuli method.
    When I delete the persistent partition                                                                                              # features/step_definitions/usb.rb:690
      FindFailed: can not find GnomeActivitiesOverview.png in S(0)[0,0 1024x768]
        Line 2171, in file Region.java
       (RuntimeError)

The video shows that we've successfully cleared all notifications but the Overview does not open.
We've pressed SUPER only 60ms after we've pressed ESC, which I think was too early: when the notifications menu is open, pressing SUPER does not open the Overview. I'll add a sleep somewhere as a workaround.

#10 Updated by intrigeri 3 months ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to test/17029+17027+17028+16931+force-all-tests

#11 Updated by intrigeri 3 months ago

  • Related to Feature #12652: Improve the 'I start ... via GNOME Activities Overview' step added

#12 Updated by intrigeri 3 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (intrigeri)
  • Target version set to Tails_4.0
  • Feature Branch changed from test/17029+17027+17028+16931+force-all-tests to https://salsa.debian.org/tails-team/tails/merge_requests/37#note_108671

#13 Updated by segfault 3 months ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF