Project

General

Profile

Bug #13461

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

The Desktop icons are sometimes not displayed since the upgrade to Stretch

Added by bertagaz over 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
-
Start date:
07/12/2017
Due date:
% Done:

20%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

Step "I log in to a new session" often fails with "FindFailed: can not find DesktopTailsDocumentation.png"

Happened 18 times in June, 41 for what 2017 logs we have.

The desktop icons are not displayed. Maybe the time to start the gnome-shell session takes a bit longer?

Elevating priority, as it can happen in all scenarios.


Related issues

Related to Tails - Feature #12289: Deal with June 2017 false positive scenarios Resolved 06/05/2017 07/05/2017
Related to Tails - Feature #11717: Drop launchers from the Desktop Rejected 08/25/2016
Related to Tails - Bug #11270: Bring back "minimize" and "maximize" buttons in titlebars by default Resolved 02/22/2016
Related to Tails - Bug #14793: Custom Desktop launchers are totally buggy Resolved 10/06/2017
Related to Tails - Bug #16283: No more icons on desktop in buster Resolved 01/05/2019

Associated revisions

Revision daf3729b (diff)
Added by intrigeri about 2 years ago

Test suite: restart nautilus-desktop if Desktop icons are not visible (refs: #13461).

Revision 6e3d57ae
Added by anonym about 2 years ago

Merge remote-tracking branch 'origin/test/13461-workaround-buggy-desktop-icons' into testing

Refs: #13461

Revision e5b7b731 (diff)
Added by Sandro Knauß 6 months ago

Remove workaround "Desktop icons are sometimes not shown" (refs: #13461)

History

#1 Updated by bertagaz over 2 years ago

  • Feature Branch set to bugfix/13462-vfat-LUKS-ext4-emergency-shutdown-scenarios-are-fragile

#2 Updated by bertagaz over 2 years ago

  • Related to Feature #12289: Deal with June 2017 false positive scenarios added

#3 Updated by intrigeri over 2 years ago

I wonder if that's a false positive of a real bug.

#4 Updated by intrigeri over 2 years ago

  • Feature Branch deleted (bugfix/13462-vfat-LUKS-ext4-emergency-shutdown-scenarios-are-fragile)

(I see no related work on that branch.)

#5 Updated by bertagaz about 2 years ago

Here's the systemd journal from https://jenkins.tails.boum.org/job/test_Tails_ISO_feature-13541-save-more-data-on-htpdate-or-tor-failures/41/ that had this problem.

To me it sounds like a real bug in the end. Might be a race condition somewhere.

#8 Updated by intrigeri about 2 years ago

  • Category deleted (Test suite)
  • Assignee changed from anonym to intrigeri
  • Type of work changed from Code to Research

bertagaz wrote:

Here's the systemd journal from https://jenkins.tails.boum.org/job/test_Tails_ISO_feature-13541-save-more-data-on-htpdate-or-tor-failures/41/ that had this problem.

To me it sounds like a real bug in the end. Might be a race condition somewhere.

I'll take a look as part of my Foundations Team work (initial investigation during the 3.2 cycle hopefully, and then I'll adjust the timeline depending on the outcome of that research).

#9 Updated by intrigeri about 2 years ago

bertagaz: thanks a lot for attaching multiple Journal outputs, I hope it'll be very helpful to try & correlate whatever error I see in there! I was lucky enough that the corresponding test runs had not been GC'ed yet, so I could also download the debug.log etc.

#10 Updated by intrigeri about 2 years ago

bertagaz wrote:

ANd another one from https://jenkins.tails.boum.org/job/test_Tails_ISO_feature-13541-save-more-data-on-htpdate-or-tor-failures/81/

For some reason the Journal for this run is incomplete, so I'll ignore it.

#11 Updated by intrigeri about 2 years ago

#12 Updated by intrigeri about 2 years ago

  • Related to Bug #11270: Bring back "minimize" and "maximize" buttons in titlebars by default added

#13 Updated by intrigeri about 2 years ago

I've looked in depth at the Journal bertagaz attached and did not find anything that rings a bell. I do see a bunch of nautilus-desktop errors, but they are also present on a Tails that does not expose this bug :/

Now, looking at the huge list of bugs in Nautilus upstream about its desktop window (and icons) management, I'm not surprised it's fragile: it's not been enabled by default in GNOME for ages and is essentially unsupported/unmaintained upstream, as raised a year ago (#11717). So I went back to the drawing board and added some ideas to get out of this situation, while hopefully making everyone except the 90's lovers happy, by replacing the desktop icons + taskbar + minimize button with a dash-to-dock thing: #11717#note-13 and #11270#note-20. But I don't expect us to make any such decision on short notice, and I'm not even looking forward to this discussion TBH, so I'll now look for short-term workarounds.

It might still be the case that this bug only occurs in our test suite, for some reason: I don't recall seeing it reported by our help desk. OTOH I'm pretty sure that most users don't use these icons, and would not even notice if they were not there, which might explain the lack of bug reports. Anyway, if this bug happens to human users, apparently they don't care, and I can't reproduce this bug on demand to implement a proper fix, so I'll focus on the needs of our robots users and will implement a work around in our test suite for now, e.g. restarting nautilus-desktop if the desktop icons are not displayed. While I'm at it I'll add some debugging info in that piece of test code, to log whether nautilus-desktop is running at all.

I'm not very happy with this outcome but my understanding of #11717#note-6 is that I should not spend too much time on nautilus-desktop bugs, so here we are.

#14 Updated by intrigeri about 2 years ago

  • Subject changed from Step "I log in to a new session" is fragile to The Desktop icons are sometimes not displayed since the upgrade to Stretch
  • Description updated (diff)

#15 Updated by anonym about 2 years ago

FWIW: I've experienced it "for real" (i.e. outside of the test suite) but still in a VM. But I've never seen it on bare metal, but I don't use it often enough for a fair comparison.

#16 Updated by intrigeri about 2 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to test/13461-workaround-buggy-desktop-icons

#17 Updated by intrigeri about 2 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check set to Ready for QA

Passed tests on Jenkins (https://jenkins.tails.boum.org/view/Tails_ISO/job/test_Tails_ISO_test-13461-workaround-buggy-desktop-icons/) but we'll see how it goes when the actually changed code is exercised. Worst case, it'll just fail a scenario, which is what would happen without this change anyway, so I think it's safe to merge.

Please don't mark this ticket as fix committed once merged as this is merely a test suite workaround, not an actual fix. I doubt I'll be able to come up with an actual fix, but let's not hide problems (especially given I have Evil™ plans to fix the root cause some day).

#18 Updated by mercedes508 about 2 years ago

I remember intri asking our help desk opinion about this ticket. Actually none of us recall seeing a bug report about this.
Our 2 cents :)

#19 Updated by anonym about 2 years ago

  • Category set to Test suite

#20 Updated by intrigeri about 2 years ago

  • Category deleted (Test suite)

(This affects actual users too, apparently.)

#21 Updated by anonym about 2 years ago

  • Category set to Test suite

#22 Updated by anonym about 2 years ago

  • Assignee changed from anonym to intrigeri
  • Target version deleted (Tails_3.2)
  • % Done changed from 10 to 20
  • QA Check deleted (Ready for QA)

Merged! It wasn't clear what you wanted to happen with the ticket afterwards, so I leave that to you.

#23 Updated by intrigeri about 2 years ago

  • Category deleted (Test suite)
  • Assignee deleted (intrigeri)
  • Feature Branch deleted (test/13461-workaround-buggy-desktop-icons)

#24 Updated by intrigeri about 2 years ago

  • Related to Bug #14793: Custom Desktop launchers are totally buggy added

#25 Updated by u over 1 year ago

  • Status changed from In Progress to Resolved

Looks like this was researched and code was merged. Closing this ticket. Please reopen if necessary.

#26 Updated by intrigeri over 1 year ago

Looks like this was researched and code was merged.

For the record this was workaround'ed in the test suite only.
But I don't think there's anything we can do about it with our current desktop.

#27 Updated by intrigeri 9 months ago

  • Related to Bug #16283: No more icons on desktop in buster added

Also available in: Atom PDF