Project

General

Profile

Bug #13460

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

Virt-viewer fails to start

Added by bertagaz over 2 years ago. Updated 2 months ago.

Status:
Confirmed
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
-
Start date:
07/12/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Happened 20 times in June, 37 for what 2017 logs we have.

It may be that restarting the VM is taking a bit more time than before, as the screenshot shows.

Setting the priority a bit higher, as it can happen in all scenarios.

01_49_11_The_tor_process_should_be_confined_with_Seccomp.png View (4.86 KB) bertagaz, 07/12/2017 11:55 AM


Related issues

Related to Tails - Feature #12289: Deal with June 2017 false positive scenarios Resolved 06/05/2017 07/05/2017

History

#1 Updated by bertagaz over 2 years ago

  • Related to Feature #12289: Deal with June 2017 false positive scenarios added

#2 Updated by intrigeri about 2 years ago

  • Target version changed from Tails_3.2 to Tails_3.3

#3 Updated by intrigeri about 2 years ago

  • Target version changed from Tails_3.3 to Tails_3.5

#4 Updated by intrigeri almost 2 years ago

  • Target version deleted (Tails_3.5)

#5 Updated by anonym 5 months ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (anonym)

I cannot remember seeing this for years → closing.

@intrigeri, @bertagaz, please reopen if you remember seeing this since "recently", perhaps since we started running the test suite on Stretch.

#6 Updated by intrigeri 5 months ago

I cannot remember seeing this for years → closing.

@anonym, I don't have the URL of the pad for the test suite migration to Buster anymore, but I wonder if I haven't seen it there. Please check that pad and hopefully I'm just having a bad dream :)

#7 Updated by anonym 5 months ago

  • Status changed from Rejected to Confirmed

intrigeri wrote:

I cannot remember seeing this for years → closing.

anonym, I don't have the URL of the pad for the test suite migration to Buster anymore, but I wonder if I haven't seen it there. Please check that pad and hopefully I'm just having a bad dream :)

I checked, and yes, you saw this problem once. Reopening.

#8 Updated by intrigeri 2 months ago

Something drew by attention in recent Debian changes. Samuel Thibault recently added a workaround, in Debian packages whose test suite uses xvfb, for a problem that looks similar: he added -s -noreset to the xvfb-run command line. In this context, -s means --server-args so that should be equivalent to passing -noreset to Xvfb (we don't use xvfb-run).

Should we try this?

References:

Also available in: Atom PDF