Project

General

Profile

Bug #13456

Running Tails 3.01 with Language German has a serious bug

Added by linuxluemmel over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Internationalization
Target version:
-
Start date:
07/12/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Greeter

Description

Running the current Tails 3.01 with the German Language has a serious bug.

Let us make a example :

I do start Tails with the following language and keyboard settings as shown in
Running-1.jpg.
As you can see in the graphics Running-2.jpg everything works fine as expected.
The language and the keyboard layout are 100 % correct.

No I do start Tails with (german-lv) and the other settings like in the first startup.
(Running-7.jpg).

As you can see inside Running-8.jpg the language of the GUI is not german.
It looks to me like Tails 3.01 took netherlands as default language. The keyboard layout is correct.

After a long time of investigation I found the solution to start Tails 3.01 with the correct settings.

Chose the correct Keyboard Layout : swiss-german
Chose the correct Format : Schweiz-Deutsch

In the language fild I do scroll until the netherlands do appear in the scroll-list .....
after that I can scroll right back to German an my Settings can be choosen.

This is shown in Running-3.jpg.
The Output with the correct Language and keyboard is shown in Running-4.jpg.

best regards

Running-1.jpg View (79.1 KB) linuxluemmel, 07/12/2017 07:47 AM

Running-2.jpg View (75 KB) linuxluemmel, 07/12/2017 07:49 AM

Running-7.jpg View (85.8 KB) linuxluemmel, 07/12/2017 07:52 AM

Running-8.jpg View (78.1 KB) linuxluemmel, 07/12/2017 07:55 AM

Running-3.jpg View (95 KB) linuxluemmel, 07/12/2017 08:03 AM

Running-4.jpg View (75.8 KB) linuxluemmel, 07/12/2017 08:04 AM


Related issues

Related to Tails - Bug #13449: German language missing from Greeter in Tails 3.0.1 Rejected 07/10/2017
Blocks Tails - Feature #13234: Core work 2017Q3: Foundations Team Resolved 06/29/2017

History

#1 Updated by mercedes508 over 2 years ago

  • Assignee set to linuxluemmel
  • QA Check deleted (Dev Needed)
  • Type of work changed from User interface design to Discuss
  • Affected tool deleted (Tor Launcher)

Hi, it looks like it's similar to the following issue: https://labs.riseup.net/code/issues/13449

#2 Updated by intrigeri over 2 years ago

  • Related to Bug #12598: Afghani keyboard selected in Greeter if typing fast added

#3 Updated by intrigeri over 2 years ago

  • Related to Bug #13449: German language missing from Greeter in Tails 3.0.1 added

#4 Updated by intrigeri over 2 years ago

  • Category changed from Accessibility to Internationalization
  • QA Check set to Info Needed
  • Type of work changed from Discuss to Research
  • Affected tool set to Greeter

linuxluemmel wrote:

No I do start Tails with (german-lv) and the other settings like in the first startup.
(Running-7.jpg).

As you can see inside Running-8.jpg the language of the GUI is not german.
It looks to me like Tails 3.01 took netherlands as default language.

You've selected "German, low - Germany", which is the nds_DE locale, i.e. https://en.wikipedia.org/wiki/Low_German. I can't tell if the Running-8.jpg screenshot is in Low German or Dutch. But if you expect Hoch Deutsch, then that's something else entirely.

Given you've tried many combinations I don't know which language / keyboard / formats you really want. If you want Hoch Deutsch, type "Deutsch" or "German" in the language search field and then select "Deutsch (German)". And if you don't see that entry, then this is a duplicate of #13449, and then please provide the debugging info I've requested on #13449#note-12 :)

Thanks in advance!

#5 Updated by intrigeri over 2 years ago

  • Related to deleted (Bug #12598: Afghani keyboard selected in Greeter if typing fast)

#6 Updated by intrigeri over 2 years ago

#7 Updated by intrigeri over 2 years ago

  • Status changed from New to Rejected

Three months later, requested info info was not provided and we cannot reproduce the bug.

Also available in: Atom PDF