Project

General

Profile

Bug #13447

Greeter: Password check doesn't work when changing first entry

Added by mercedes508 over 2 years ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
07/09/2017
Due date:
% Done:

100%

Feature Branch:
https://salsa.debian.org/tails-team/tails/merge_requests/39/commits
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Greeter

Description

In Tails 3.0.1 (and previous), at Greeter, when setting an administration password the following way, you don't get any error message, but can't get and admin terminal neither:

Procedure =========

  • go to the admin password part of the Greeter
  • in the first field type your password, but wrongly (let's say "possword")
  • in the second field type the right one (let's say "password")

You get a notice that it doesn't match

  • change the password in the first field to the right one ("password")

You get a notice that it matches

  • Start Tails

Result ======

Can't open/use an admin password.


Related issues

Related to Tails - Bug #12386: Greeter sometimes fails to set Admin password on Stretch Duplicate 03/19/2017
Related to Tails - Feature #14544: Spend software developer time on smallish UX improvements In Progress 08/31/2018
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed
Blocked by Tails - Feature #16095: Curate the list of languages in Tails Greeter Resolved 11/04/2018

Associated revisions

Revision 2b6b2775 (diff)
Added by segfault about 2 months ago

Fix admin password not applied in some cases (refs: #13447, #17087)

Revision 53c6c19a
Added by intrigeri about 1 month ago

Merge branch 'feature/17098-refactor-greeter' into devel (Closes: #17098, #17089, #16806, #13447, #17087, #17058, #17101, #6525, #16095, #16094, #16093)

History

#1 Updated by intrigeri over 2 years ago

  • Parent task set to #11643

#2 Updated by intrigeri over 2 years ago

  • Related to Bug #12386: Greeter sometimes fails to set Admin password on Stretch added

#3 Updated by u almost 2 years ago

Still confirmed in Tails 3.4.

I propose to merge #12386 and #13447. It seems to be the same bug.

It might be that the problem is simply that the Greeter expects us to focus the second field before clicking add? (I have not tested that idea.)

#4 Updated by u almost 2 years ago

u wrote:

Still confirmed in Tails 3.4.

I propose to merge #12386 and #13447. It seems to be the same bug.

It might be that the problem is simply that the Greeter expects us to focus the second field before clicking add? (I have not tested that idea.)

I confirm that everything works correctly when following the procedure described in the ticket and then refocusing the second text field.

#5 Updated by sajolida 10 months ago

  • Related to Feature #14544: Spend software developer time on smallish UX improvements added

#6 Updated by sajolida 10 months ago

  • Parent task deleted (#11643)

#7 Updated by sajolida 3 months ago

Alan hasn't touched this ticket since it was created about 2 years ago and I think that we should unblock it.

#8 Updated by intrigeri 3 months ago

#9 Updated by intrigeri 3 months ago

  • Assignee deleted (alant)

sajolida wrote:

Alan hasn't touched this ticket since it was created about 2 years ago and I think that we should unblock it.

Yes, let's make it clear that this one is up for grabs, and could be tackled by any FT member: there's no particular reason why we need to block on Alan here.

#10 Updated by segfault about 2 months ago

  • Assignee set to segfault

#11 Updated by segfault about 2 months ago

  • Status changed from Confirmed to In Progress

#12 Updated by segfault about 2 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)
  • Feature Branch set to feature/16095-curate-languages-in-greeter

#13 Updated by segfault about 2 months ago

  • Subject changed from Inconsistent administration password setting process at Greeter to Greeter: Password check doesn't work when changing first entry

#14 Updated by segfault about 2 months ago

  • Target version set to Tails_4.0

#15 Updated by intrigeri about 2 months ago

  • Assignee set to intrigeri

#16 Updated by intrigeri about 2 months ago

Code review passes, will now build & test.

#17 Updated by intrigeri about 2 months ago

  • Blocked by Feature #16095: Curate the list of languages in Tails Greeter added

#18 Updated by intrigeri about 2 months ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from intrigeri to segfault

Works! Please reassign to me once the branch is ready for merging.

#19 Updated by segfault about 1 month ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)
  • Feature Branch changed from feature/16095-curate-languages-in-greeter to https://salsa.debian.org/tails-team/tails/merge_requests/39/commits

#20 Updated by intrigeri about 1 month ago

  • Assignee set to intrigeri

#21 Updated by intrigeri about 1 month ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF