Project

General

Profile

Bug #13440

Feature #5630: Reproducible builds

Bug #12740: Various .cache files not reproducible in some environments

GTK immodules.cache not reproducible

Added by anonym over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Build system
Target version:
Start date:
07/07/2017
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/13440-reproducible-gtk2.0-immodules.cache
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules.cache
/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules.cache

See parent ticket for more info.

diffoscope.html View (201 KB) intrigeri, 09/10/2017 05:31 PM

diffoscope.html View (312 KB) intrigeri, 09/11/2017 01:01 PM

diffoscope.txt.bz2 (6.83 KB) intrigeri, 09/12/2017 09:47 AM

immodules.cache.bad (1.93 KB) anonym, 09/12/2017 05:31 PM

immodules.cache.good (2.06 KB) anonym, 09/12/2017 05:31 PM

gtk+3.0.diff.txt View - gtk+3.0.diff.txt (1019 Bytes) lamby, 09/13/2017 06:48 PM

Associated revisions

Revision 91e0f653 (diff)
Added by anonym over 1 year ago

Add the bugfix-13440-reproducible-gtk2.0-immodules.cache APT overlay.

Will-fix: #13440-reproducible-gtk2.0immodules.cache

Revision 8c859268
Added by anonym over 1 year ago

Merge branch 'bugfix/13440-reproducible-gtk2.0-immodules.cache' into devel

Fix-committed: #13440

History

#1 Updated by intrigeri over 1 year ago

  • Target version set to Tails_3.1

(Like parent ticket.)

#2 Updated by anonym over 1 year ago

  • Target version changed from Tails_3.1 to Tails_3.2

#3 Updated by lamby over 1 year ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from lamby to anonym

I've fixed this upstream here:

https://bugzilla.gnome.org/show_bug.cgi?id=786528

It applies against the stretch version of src:gtk+2.0 with a small offset.

Enjoy!

#4 Updated by intrigeri over 1 year ago

  • QA Check set to Ready for QA
  • Type of work changed from Research to Code

Yeah :)

#6 Updated by lamby over 1 year ago

I've updated the patch upstream.

#7 Updated by intrigeri over 1 year ago

  • Priority changed from Normal to Elevated

#8 Updated by anonym over 1 year ago

  • % Done changed from 0 to 50
  • Feature Branch set to bugfix/13440-reproducible-gtk2.0-immodules.cache

#9 Updated by intrigeri over 1 year ago

kurono's 3.2~alpha2 ISO has a problem in this, see attached diffoscope output. Looks like things get sorted in a different order.

#10 Updated by intrigeri over 1 year ago

Another Tails contributor reported FTBR of 3.1~alpha2 with the same problem, diffoscope output attached.

#11 Updated by intrigeri over 1 year ago

And a third one.

#12 Updated by anonym over 1 year ago

  • Assignee changed from anonym to lamby

lamby, is there any chance you could try to have a look and provide us a fix before 13:00 2017-09-14 UTC so we might have this fix in Tails 3.2~rc1?

#13 Updated by lamby over 1 year ago

  • Assignee changed from lamby to anonym

anonym wrote:

lamby, is there any chance you could try to have a look and provide us a fix before 13:00 2017-09-14 UTC so we might have this fix in Tails 3.2~rc1?

Sure, but can you confirm my patch was applied when building this ISO? I don't see anything about it being merged here...

#14 Updated by anonym over 1 year ago

  • Assignee changed from anonym to lamby

tl;dr: I confirm your patch was applied in 3.2~alpha2.

More explanation: https://labs.riseup.net/code/issues/13442#note-12

#15 Updated by anonym over 1 year ago

Here's the good file and one of the bad files (not necessarily the same as in any of the diffoscope reports here).

#16 Updated by anonym over 1 year ago

Another bad one (one week expiry): https://share.riseup.net/#9Vu1ZqDb49EUiSiPT0EaBA

#17 Updated by lamby over 1 year ago

After a lot of head-scratching and testing my code and being like "but it works dammit!!" I realised this was because we have a code copy of this patch, one for gtk+2.0 and gtk+3.0.

We now have two bugs in the Debian BTS tracking this:

https://bugs.debian.org/872729 (GTK2)
https://bugs.debian.org/875700 (GTK3)

Attaching patch for gtk+3.0.

Enjoy :)

#18 Updated by intrigeri over 1 year ago

  • QA Check changed from Dev Needed to Ready for QA

Thanks a lot Chris!

#19 Updated by anonym over 1 year ago

gtk+3.0 packages built and uploaded. If Jenkins is fine with the branch, I'll merge.

#20 Updated by anonym over 1 year ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#21 Updated by anonym over 1 year ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#22 Updated by anonym over 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF