Project

General

Profile

Bug #13413

torproject time-based snapshots for stretch pull from buster

Added by anonym over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
07/04/2017
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

While working on #13253 I first tried to be efficient by just bumping the torprojet snapshot to pull the new Tor 0.3.0.9. Specifically we expect to get 0.3.0.9-1~d90.stretch+1 but we get 0.3.0.9-1~d99.buster+1 (also affects devel).

Our APT pinnings look good; actually it seems the time-based snapshot is wrong, cause the 2017070402 torproject snapshot for stretch has version 0.3.0.9-1~d99.buster+1, which seems wrong.

Starting with an elevated priority since if this affects e.g. the debian snapshots this probably could be serious.


Related issues

Blocks Tails - Feature #13233: Core work 2017Q3: Sysadmin (Maintain our already existing services) Resolved 06/29/2017
Blocks Tails - Bug #13416: Restore APT pinning of deb.tp.o Resolved 07/04/2017

Associated revisions

Revision 0e8ef1fe (diff)
Added by anonym over 2 years ago

Temporarily prioritize deb.t.b.o over deb.tp.o.

So we install 0.3.0.9-1~d90.stretch+1 (from deb.t.b.o) instead of
0.3.0.9-1~d99.buster+1 (from deb.tp.o, or rather our snapshot of it
which incorrectly has this Debian buster version of the package,
refs: #13413).

Will-fix: #13253

History

#1 Updated by intrigeri over 2 years ago

  • Blocks Feature #13233: Core work 2017Q3: Sysadmin (Maintain our already existing services) added

#2 Updated by anonym over 2 years ago

  • Blocks Bug #13416: Restore APT pinning of deb.tp.o added

#3 Updated by intrigeri over 2 years ago

  • Subject changed from time-based snapshots for stretch can contain versions from buster to torproject time-based snapshots for stretch pull from buster
  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Type of work changed from Research to Sysadmin

Hopefully fixed with https://git-tails.immerda.ch/puppet-tails/commit/?id=bc21029ac192289b28284a76bc1fa73264c73391, we'll see (next update runs at 17:41 CEST).

#4 Updated by intrigeri over 2 years ago

  • Priority changed from Elevated to Normal
  • Target version set to Tails_3.1

anonym wrote:

Starting with an elevated priority since if this affects e.g. the debian snapshots this probably could be serious.

I've double checked and it doesn't affect any other archive we take snapshot from.

#5 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 10 to 100

Also available in: Atom PDF