Project

General

Profile

Feature #13241

Feature #13246: Core work

Core work: Test suite maintenance

Added by intrigeri over 2 years ago. Updated 9 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
-
Start date:
06/29/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

This is about the critical maintenance: "Maintaining the test suite across technical migrations".


Related issues

Related to Tails - Feature #13240: Core work 2017Q4: Test suite maintenance Resolved 06/29/2017
Related to Tails - Feature #13239: Core work 2017Q3: Test suite maintenance Resolved 06/29/2017
Blocked by Tails - Bug #14935: Future-proof the test suite vs future fundraising campaign headers Resolved 11/08/2017
Blocked by Tails - Feature #15379: Adjust test suite to Python tails-upgrade-frontend-wrapper Resolved 03/05/2018
Blocked by Tails - Feature #8514: Replace WhisperBack.mail_appended_info with a dictionary Resolved 01/02/2015
Blocked by Tails - Feature #15701: Adapt and run our test suite for Tor Browser 8 Resolved 07/03/2018
Blocked by Tails - Bug #15762: Automated tests for adding a certificate to Pidgin stopped working Resolved 08/01/2018
Blocked by Tails - Bug #15771: OpenPGP key fetch tests started failing Resolved 08/08/2018
Blocked by Tails - Bug #15791: Update test suite for Thunderbird 60 Resolved 08/15/2018
Blocked by Tails - Bug #15799: "Additional software packages are installed even without network" test always fail in my environment Resolved 08/17/2018
Blocked by Tails - Bug #16237: Pidgin test failure since the move to redmine.tails.boum.org Resolved 12/22/2018
Blocked by Tails - Bug #16269: Improve doc for the automated test suite Resolved 01/04/2019
Blocked by Tails - Bug #16351: "Anti test: Detecting UDP leaks of DNS lookups with the firewall leak detector" fails on Jenkins Resolved 01/13/2019
Blocked by Tails - Bug #16555: Thunderbird "my Thunderbird inbox is non-empty" test consistently fails Resolved 03/14/2019

History

#1 Updated by intrigeri over 2 years ago

  • Related to Feature #13240: Core work 2017Q4: Test suite maintenance added

#2 Updated by intrigeri over 2 years ago

  • Related to Feature #13239: Core work 2017Q3: Test suite maintenance added

#3 Updated by intrigeri over 2 years ago

  • Parent task set to #13250

#4 Updated by intrigeri about 2 years ago

  • Target version changed from Tails_4.0 to Tails_3.7

#5 Updated by anonym almost 2 years ago

  • Blocked by Feature #15020: Support running multiple instances of the automated test suite on the same system added

#6 Updated by intrigeri almost 2 years ago

  • Blocked by Bug #14935: Future-proof the test suite vs future fundraising campaign headers added

#7 Updated by intrigeri almost 2 years ago

  • Blocked by Bug #15006: Test suite regression: "I successfully start the Unsafe Browser" fails since Tails 3.3 added

#8 Updated by intrigeri almost 2 years ago

  • Blocked by Bug #11890: Checking credentials in Thunderbird autoconfig wizard sometimes fails in the test suite added

#9 Updated by intrigeri almost 2 years ago

  • Blocked by deleted (Feature #15020: Support running multiple instances of the automated test suite on the same system)

#10 Updated by anonym almost 2 years ago

#11 Updated by intrigeri over 1 year ago

  • Blocked by deleted (Bug #11890: Checking credentials in Thunderbird autoconfig wizard sometimes fails in the test suite)

#12 Updated by intrigeri over 1 year ago

  • Subject changed from Core work 2018Q1: Test suite maintenance to Core work 2018Q2 → 20189Q1: Test suite maintenance
  • Target version changed from Tails_3.7 to Tails_3.12
  • Parent task changed from #13250 to #13246

Repurposing this ticket: none of the blocking tickets were completed in 2018Q1 so we're not losing any info, and let's make the overhead lighter by using a single ticket to track this work over the whole year.

#13 Updated by intrigeri over 1 year ago

  • Subject changed from Core work 2018Q2 → 20189Q1: Test suite maintenance to Core work 2018Q2 → 2019Q1: Test suite maintenance

#14 Updated by intrigeri over 1 year ago

  • Description updated (diff)

#15 Updated by intrigeri over 1 year ago

  • Blocked by Feature #15379: Adjust test suite to Python tails-upgrade-frontend-wrapper added

#16 Updated by intrigeri over 1 year ago

  • Blocked by Bug #15460: Test suite broken with Java 9+ added

#17 Updated by intrigeri over 1 year ago

  • Subject changed from Core work 2018Q2 → 2019Q1: Test suite maintenance to Core work 2018Q2 → 2019Q2: Test suite maintenance

#18 Updated by intrigeri over 1 year ago

  • Blocked by Feature #8514: Replace WhisperBack.mail_appended_info with a dictionary added

#19 Updated by intrigeri over 1 year ago

  • Blocked by Feature #15701: Adapt and run our test suite for Tor Browser 8 added

#20 Updated by intrigeri over 1 year ago

#21 Updated by intrigeri over 1 year ago

  • Blocked by Bug #15762: Automated tests for adding a certificate to Pidgin stopped working added

#22 Updated by intrigeri over 1 year ago

  • Blocked by Bug #15771: OpenPGP key fetch tests started failing added

#23 Updated by intrigeri over 1 year ago

  • Blocked by Bug #15791: Update test suite for Thunderbird 60 added

#24 Updated by intrigeri over 1 year ago

  • Blocked by Bug #15799: "Additional software packages are installed even without network" test always fail in my environment added

#25 Updated by intrigeri over 1 year ago

  • Blocked by Bug #15914: Update (or remove) some manual Thunderbird tests added

#26 Updated by intrigeri about 1 year ago

  • Blocked by Feature #15286: Adapt automated test suite for the "one single SquashFS diff" upgrade scheme added

#27 Updated by intrigeri about 1 year ago

#28 Updated by intrigeri about 1 year ago

  • Blocked by Bug #16069: "Only the expected addons are installed" Thunderbird test is buggy added

#29 Updated by intrigeri 11 months ago

  • Blocked by Bug #16237: Pidgin test failure since the move to redmine.tails.boum.org added

#30 Updated by intrigeri 11 months ago

  • Blocked by Bug #16269: Improve doc for the automated test suite added

#31 Updated by intrigeri 11 months ago

  • Blocked by Bug #16281: Update the test suite for Buster added

#32 Updated by intrigeri 11 months ago

  • Blocked by Bug #16351: "Anti test: Detecting UDP leaks of DNS lookups with the firewall leak detector" fails on Jenkins added

#33 Updated by intrigeri 10 months ago

  • Assignee changed from anonym to intrigeri
  • Target version changed from Tails_3.12 to Tails_3.15

#34 Updated by intrigeri 9 months ago

  • Blocked by Bug #13541: Tor still sometimes fails to bootstrap in the test suite added

#35 Updated by intrigeri 9 months ago

  • Blocked by Bug #10495: The 'the time has synced' step is fragile added

#36 Updated by intrigeri 9 months ago

  • Blocked by Bug #10442: Totem "Watching a WebM video over HTTPS" test never passes on Jenkins added

#37 Updated by intrigeri 9 months ago

  • Blocked by Bug #16555: Thunderbird "my Thunderbird inbox is non-empty" test consistently fails added

#38 Updated by intrigeri 9 months ago

  • Subject changed from Core work 2018Q2 → 2019Q2: Test suite maintenance to Core work: Test suite maintenance

#39 Updated by intrigeri 9 months ago

  • Assignee deleted (intrigeri)
  • Target version deleted (Tails_3.15)

#40 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #10442: Totem "Watching a WebM video over HTTPS" test never passes on Jenkins)

#41 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #10495: The 'the time has synced' step is fragile)

#42 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #13541: Tor still sometimes fails to bootstrap in the test suite)

#43 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15006: Test suite regression: "I successfully start the Unsafe Browser" fails since Tails 3.3)

#44 Updated by intrigeri 9 months ago

#45 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #16069: "Only the expected addons are installed" Thunderbird test is buggy)

#46 Updated by intrigeri 9 months ago

  • Blocked by deleted (Feature #15286: Adapt automated test suite for the "one single SquashFS diff" upgrade scheme)

#47 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #16281: Update the test suite for Buster)

#48 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15460: Test suite broken with Java 9+)

#49 Updated by intrigeri 9 months ago

  • Blocked by deleted (Bug #15914: Update (or remove) some manual Thunderbird tests)

#50 Updated by intrigeri 9 months ago

  • Status changed from Confirmed to Rejected

Also available in: Atom PDF