Project

General

Profile

Feature #13178

Upgrade to Stretch 9.1 in Tails 3.1

Added by intrigeri over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
07/22/2017
Due date:
% Done:

100%

Feature Branch:
feature/13178-stretch-9.1
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Usually we don't update to Debian stable point-releases in a Tails point-release, but a Debian r1 (first point-release after the initial stable release) generally brings tons of bugfixes that we might want. The RM for 3.1 (bertagaz) agreed to consider pulling these fixes.

Here's what it will include:

https://release.debian.org/proposed-updates/stable.html

Let's set up a branch with stretch-proposed-updates enabled, so we can evaluate the impact.


Related issues

Related to Tails - Bug #12543: Keyboard layout chosen in the Greeter is sometimes not applied to the session once logged in Resolved 05/16/2017
Blocks Tails - Feature #13234: Core work 2017Q3: Foundations Team Resolved 06/29/2017

Associated revisions

Revision 92ed7ad0 (diff)
Added by intrigeri over 2 years ago

Bump APT snapshots for the Debian and Tor archives to 2017072302, i.e. upgrade to the Stretch 9.1 point-release (refs: #13178).

Revision 4e0da228
Added by bertagaz over 2 years ago

Merge remote-tracking branch 'origin/feature/13178-stretch-9.1' into stable

Fix-committed: #13178

History

#1 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to feature/13178-stretch-9.1

#2 Updated by intrigeri over 2 years ago

So far the diff (for ext in build-manifest packages ; do echo "### $ext" ; diff -Naur <(curl -s https://nightly.tails.boum.org/build_Tails_ISO_stable/lastSuccessful/archive/latest.iso.$ext) <(curl -s https://nightly.tails.boum.org/build_Tails_ISO_feature-13178-stretch-9.1/lastSuccessful/archive/latest.iso.$ext) ; done) looks like something we totally want, but of course let's reconsider closer in a few weeks.

#3 Updated by intrigeri over 2 years ago

#4 Updated by intrigeri over 2 years ago

  • Related to Bug #12543: Keyboard layout chosen in the Greeter is sometimes not applied to the session once logged in added

#5 Updated by intrigeri over 2 years ago

  • % Done changed from 10 to 20
The first point release for "stretch" (9.1) is scheduled for Saturday,
July 22nd. Processing of new uploads into stretch-proposed-updates will
be frozen during the preceding weekend.

… so the current state of stretch-p-u should now be what'll become Stretch 9.1. I'll wait until the actual release though before rebasing the topic branch on top of stable, with bumped APT snapshots (and without stretch-p-u).

The packages / build-manifest diff still looks good, and #12543#note-28 feels like a strong additional reason to take r1. I've had a look at test suite results on Jenkins and I didn't spot obvious regressions. So I'm now quite convinced we should take r1 in Tails 3.1.

#6 Updated by intrigeri over 2 years ago

Stretch 9.1 is out. https://jenkins.tails.boum.org/job/build_Tails_ISO_devel/2470/ will be the first build of devel that uses it. I'll check how it goes and will update the topic branch (with a set of bumped, frozen APT snapshots) if happy.

#7 Updated by intrigeri over 2 years ago

  • Related to Bug #13504: Rebase our custom squashfs-tools package on 1:4.3-3+deb9u1 added

#8 Updated by intrigeri over 2 years ago

  • % Done changed from 20 to 30

Packages diff looks OK, now waiting for test suite results.

#10 Updated by intrigeri over 2 years ago

Hard-reset the topic branch on top of stable, bumped APT snapshots to 2017072302 & bumped these snapshots expiration date so they will expire on October 20. Now, I think that the resulting ISO won't be reproducible anymore until I handle #13504.

#11 Updated by intrigeri over 2 years ago

  • Related to deleted (Bug #13504: Rebase our custom squashfs-tools package on 1:4.3-3+deb9u1)

#12 Updated by intrigeri over 2 years ago

  • Subject changed from Consider upgrading to Stretch 9.1 in Tails 3.1 to Upgrade to Stretch 9.1 in Tails 3.1
  • Assignee changed from intrigeri to bertagaz
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

#13 Updated by bertagaz over 2 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (bertagaz)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

https://jenkins.tails.boum.org/job/test_Tails_ISO_feature-13178-stretch-9.1/29/ passed.

Looks good, merged for 3.1!

#14 Updated by intrigeri over 2 years ago

Looks good, merged for 3.1!

Great. I've handled the merge into devel once again (you forgot to do it for most of the merges you did recently, please get used to doing it otherwise devel lacks stuff that's in stable, which can be very confusing).

I've made it so the time-based APT snapshots used for 3.0.1 will expire on August 21 (instead of some time in December previously), so that some storage space is reclaimed there ASAP.

#15 Updated by bertagaz over 2 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF