Project

General

Profile

Bug #13175

Nautilus archive manager 'extract here' menu option fails with .7z files, but Archive manager not.

Added by emmapeel over 2 years ago. Updated about 1 year ago.

Status:
Confirmed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
06/27/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:

Description

Reported by user, confirmed by me:

Nautilus context menu option 'Extract here', which is the default option and gets also activated when you double click on the file, fails to open

Steps to reproduce:

- Get a .7z password encrypted file [1]
- Move it to Tor Browser folder
- Right-click and select default option 'Extract here'
- You get an Error message: empty archive.

BUT:

- Get a .7z password encrypted file [1]
- Move it to Tor Browser folder
- Right-click and select 'Open with other application'
- Select Archive manager
- You get prompted for the password and everything goes well

[1] Attached here, password 'tete', created with Archive manager itself (more options, encrypt file list also)

test-archive.7z (88.3 KB) emmapeel, 06/27/2017 08:35 AM


Related issues

Duplicated by Tails - Bug #13580: Archive manager cannot extract password protected 7z files Duplicate 08/04/2017

History

#1 Updated by intrigeri over 2 years ago

  • Assignee set to emmapeel
  • QA Check deleted (Dev Needed)
  • Type of work changed from Code to Communicate

I doubt that's Tails-specific, it looks like a limitation of the native archives support that was added in Nautilus. Given there's a workaround, and I bet it affects very few users (wrong?), I'm inclined to say it's not something we should spend any time on. So please report this upstream (to Debian or to GNOME) after reproducing on pristine + recent Debian or Fedora, and then let's close this. Or just close it if you prefer.

#2 Updated by intrigeri almost 2 years ago

  • Duplicated by Bug #13580: Archive manager cannot extract password protected 7z files added

#3 Updated by u about 1 year ago

If you are not interested in reporting this bug upstream or at least to Debian, please close this ticket.

Also available in: Atom PDF