Project

General

Profile

Bug #12909

Feature #5630: Reproducible builds

Bug #12740: Various .cache files not reproducible in some environments

/var/cache/cracklib/src-dicts not reproducible

Added by lamby over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
06/23/2017
Due date:
% Done:

100%

Feature Branch:
bugfix/12909-reproducible-cracklib2-dicts
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

​/​usr/​share/​dict/​README.​select-​wordlist·​/​usr/​share/​dict/​cracklib-​small·​/​usr/​share/​dict/​american-​english

vs

·​/​usr/​share/​dict/​american-​english·​/​usr/​share/​dict/​README.​select-​wordlist·​/​usr/​share/​dict/​cracklib-​small

via https://labs.riseup.net/code/issues/12738#note-1

Associated revisions

Revision d70e0082 (diff)
Added by anonym over 2 years ago

Add the bugfix-12909-reproducible-cracklib2-dicts APT overlay

Will-fix: #12909

Revision adf4d475
Added by bertagaz over 2 years ago

Merge remote-tracking branch 'origin/bugfix/12909-reproducible-cracklib2-dicts' into stable

Fix-committed: #12909

History

#3 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from lamby to anonym
  • % Done changed from 0 to 30
  • Type of work changed from Research to Code

It looks like next step is: anonym applies this patch and uploads a package to our custom APT repo.

#4 Updated by intrigeri over 2 years ago

  • Parent task changed from #5630 to #12740

#5 Updated by anonym over 2 years ago

  • Assignee changed from anonym to bertagaz
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/12909-reproducible-cracklib2-dicts

Let's see what Jenkins thinks: https://jenkins.tails.boum.org/job/test_Tails_ISO_bugfix-12909-reproducible-cracklib2-dicts/

bert, it's doubtful I'll have time to look at the results before you start building Tails 3.1 tomorrow. Would you consider review'n'merging this branch any way if you get the time?

#6 Updated by bertagaz over 2 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (bertagaz)
  • % Done changed from 30 to 100
  • QA Check changed from Ready for QA to Pass

anonym wrote:

Let's see what Jenkins thinks: https://jenkins.tails.boum.org/job/test_Tails_ISO_bugfix-12909-reproducible-cracklib2-dicts/

bert, it's doubtful I'll have time to look at the results before you start building Tails 3.1 tomorrow. Would you consider review'n'merging this branch any way if you get the time?

I did, tests pass, ISO is reproducible, so I've merged it for 3.1.

#7 Updated by lamby over 2 years ago

bertagaz wrote:

I did, tests pass, ISO is reproducible

Sorry for "noise", but \o/ \o/ \o/ \o/ \o/

#8 Updated by u over 2 years ago

\o/ amazing!

#9 Updated by bertagaz over 2 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF