Project

General

Profile

Bug #12737

Feature #5630: Reproducible builds

utils/ not reproducible in some environments

Added by anonym over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
06/19/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

See #12608#note-18 for arnaud's diffoscope report. There are also .torrent:s for the good ISO, and for arnaud's.

This might just be another instance of #12608#note-2 because the diff looks like:

  Directory listing of /utils/linux/
│  d---------   0    0    0            2048 May 21 2017 [     51 02]  . 
│  d---------   0    0    0            2048 May 21 2017 [     50 02]  .. 
│ -----------   0    0    0          200312 May 21 2017 [ 588009 00]  syslinux.;1 
│ +----------   0    0    0          200312 May 21 2017 [ 588345 00]  syslinux.;1 
│  
│  Directory listing of /utils/mbr/
│  d---------   0    0    0            2048 May 21 2017 [     52 02]  . 
│  d---------   0    0    0            2048 May 21 2017 [     50 02]  .. 
│ -----------   0    0    0             440 May 21 2017 [ 588107 00]  mbr.bin;1 
│ +----------   0    0    0             440 May 21 2017 [ 588443 00]  mbr.bin;1 
│  
│  Directory listing of /utils/win32/
│  d---------   0    0    0            2048 May 21 2017 [     53 02]  . 
│  d---------   0    0    0            2048 May 21 2017 [     50 02]  .. 
│ -----------   0    0    0          243712 May 21 2017 [ 588108 00]  syslinux.exe;1 
│ +----------   0    0    0          243712 May 21 2017 [ 588444 00]  syslinux.exe;1

I.e. only "extents" are shifted, which is expected since live/filesystem.squashfs got a size that was almost 10 MiB larger.

History

#1 Updated by anonym over 2 years ago

  • Assignee set to lamby
  • QA Check set to Info Needed

If you can confirm my suspicion, I think we're done here.

#2 Updated by intrigeri over 2 years ago

  • Parent task set to #5630

#3 Updated by lamby over 2 years ago

  • Status changed from Confirmed to Duplicate
  • % Done changed from 0 to 100

Agree re. "bleed" hypothesis. Closing as duplicate.

#4 Updated by anonym over 2 years ago

  • Assignee deleted (lamby)
  • % Done changed from 100 to 0
  • QA Check deleted (Info Needed)

Also available in: Atom PDF