Project

General

Profile

Bug #12736

Feature #5630: Reproducible builds

live/vmlinuz not reproducible in some environments

Added by anonym over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Build system
Target version:
Start date:
06/19/2017
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

See #12608#note-18 for arnaud's diffoscope report. There are also .torrent:s for the good ISO, and for arnaud's.

The diff is huge, so the uncompressed data likely contains several differences.

History

#1 Updated by anonym over 2 years ago

  • Assignee set to lamby
  • QA Check set to Info Needed

Could you have a look?

#2 Updated by intrigeri over 2 years ago

Wow, a different kernel?! That's seriously weird.

#3 Updated by anonym over 2 years ago

Actually, I must have made a mistake when I initially "determined" that the kernels differ, because they don't. The only difference is:

│ -----------   0    0    0      1174503424 May 21 2017 [   2192 00]  filesystem.squashfs;1 
│ -----------   0    0    0        21043456 May 21 2017 [ 575680 00]  initrd.img;1 
│ -----------   0    0    0         4204320 May 21 2017 [ 585956 00]  vmlinuz.;1 
│ +----------   0    0    0      1175322624 May 21 2017 [   2192 00]  filesystem.squashfs;1 
│ +----------   0    0    0        20913280 May 21 2017 [ 576080 00]  initrd.img;1 
│ +----------   0    0    0         4204320 May 21 2017 [ 586292 00]  vmlinuz.;1

I.e. a shift in the extents since files written earlier had different sizes. So it's probably just another instance of #12737.

#4 Updated by intrigeri over 2 years ago

  • Parent task set to #5630

#5 Updated by lamby over 2 years ago

  • Status changed from Confirmed to Duplicate
  • % Done changed from 0 to 100

Agree re. "bleed" hypothesis. Closing as duplicate.

Also available in: Atom PDF