Project

General

Profile

Feature #12732

Upgrade Linux to 4.12

Added by intrigeri over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
06/18/2017
Due date:
% Done:

100%

Feature Branch:
feature/12732-linux-4.12
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Linux 4.11 is now in Debian testing. It's likely it (or 4.12) will make it into stretch-backports in time for Tails 3.2. Let's get ready for it.


Related issues

Blocks Tails - Bug #12730: Laptop screen with lid closed is configured as the primary display Resolved 06/17/2017
Blocks Tails - Feature #13234: Core work 2017Q3: Foundations Team Resolved 06/29/2017
Blocks Tails - Bug #11831: NVIDIA Maxwell series graphic card: X.Org doesn't start, or slow graphics operations Resolved 04/10/2017

Associated revisions

Revision a402ef15 (diff)
Added by intrigeri over 2 years ago

Install Linux 4.11 from Debian unstable (refs: #12732).

Revision bb24df18 (diff)
Added by intrigeri over 2 years ago

Install Linux 4.12 from Debian unstable (refs: #12732).

Revision c476f7e8 (diff)
Added by intrigeri over 2 years ago

Install aufs-dkms from Debian unstable (refs: #12732).

Revision 54e58e8f
Added by anonym over 2 years ago

Merge remote-tracking branch 'origin/feature/12732-linux-4.12' into devel

Fix-committed: #12732, #11831, #12730

History

#1 Updated by intrigeri over 2 years ago

  • Description updated (diff)

#2 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to feature/12732-linux-4.11

#3 Updated by intrigeri over 2 years ago

  • Type of work changed from Code to Wait

Builds fine but does not boot due to the lack of aufs support: https://bugs.debian.org/865614.

#4 Updated by intrigeri over 2 years ago

  • Feature Branch changed from feature/12732-linux-4.11 to wip/feature/12732-linux-4.11

(Let's not waste Jenkins isotesters on a branch that cannot boot.)

#5 Updated by intrigeri over 2 years ago

  • Related to Bug #12730: Laptop screen with lid closed is configured as the primary display added

#6 Updated by intrigeri over 2 years ago

  • Related to deleted (Bug #12730: Laptop screen with lid closed is configured as the primary display)

#7 Updated by intrigeri over 2 years ago

  • Blocks Bug #12730: Laptop screen with lid closed is configured as the primary display added

#8 Updated by intrigeri over 2 years ago

#9 Updated by intrigeri over 2 years ago

  • Description updated (diff)

#10 Updated by intrigeri over 2 years ago

  • Related to Bug #11831: NVIDIA Maxwell series graphic card: X.Org doesn't start, or slow graphics operations added

#11 Updated by intrigeri over 2 years ago

  • Subject changed from Upgrade Linux to 4.11 to Upgrade Linux to 4.12

stretch-backports now has 4.11.6-1~bpo9+1 (which might not be affected by the dkms issue that's been blocking this ticket so far), but it's lagging behind sid (4.11.11-1) due to RC bugs preventing transition to testing, so I'm not confident with pulling it in Tails. And 4.12.6-1 just got uploaded to sid, so let's bet on that one instead. I'll update my branch once binary packages are available.

#12 Updated by intrigeri over 2 years ago

  • Feature Branch changed from wip/feature/12732-linux-4.11 to feature/12732-linux-4.12

#13 Updated by intrigeri over 2 years ago

  • Type of work changed from Wait to Code

The branch now builds fine & the resulting ISO boots. Some tests fail on Jenkins for reasons that seem related to the testing environment more than to this branch; I'll investigate.

#14 Updated by intrigeri over 2 years ago

  • Related to deleted (Bug #11831: NVIDIA Maxwell series graphic card: X.Org doesn't start, or slow graphics operations)

#15 Updated by intrigeri over 2 years ago

  • Blocks Bug #11831: NVIDIA Maxwell series graphic card: X.Org doesn't start, or slow graphics operations added

#16 Updated by intrigeri over 2 years ago

  • % Done changed from 10 to 20

intrigeri wrote:

Some tests fail on Jenkins for reasons that seem related to the testing environment more than to this branch; I'll investigate.

As a workaround I've grown /tmp/TailsToaster on isotester*.lizard. I'm now testing if that's enough & doesn't cause regressions elsewhere (worst case I'll also give more RAM to our isotesters).

It seems the problem is that every snapshot (*.memstate) takes 2GB on "disk" when the guest VM runs Linux 4.12, regardless of how much RAM is really used in the VM, while with Linux 4.9 they're smaller (e.g. I see 955MB for tails-greeter-snapshot.memstate and 1.4GB for no-network-logged-in-snapshot.memstate). I suspect that some new hardening feature (e.g. the kernel initializing memory when it's allocated?) marks all memory as used, therefore preventing QEMU from saving a smaller snapshot, and then there's nothing we can do about it: we simply need to live with it and allocate more space to /tmp/TailsToaster. anonym, as our snapshots expert, it would be nice if you can have a look at this, but don't spend more than 1 hour on it since the workaround is trivial.

#17 Updated by intrigeri over 2 years ago

Woohoo, test suite passed on Jenkins https://jenkins.tails.boum.org/view/Tails_ISO/job/test_Tails_ISO_feature-12732-linux-4.12/16/ except one issue that's recurring on other branches anyway (I expect I'll flag it as fragile when triaging August false positives).

#18 Updated by intrigeri over 2 years ago

Next step: install from stretch-backports, that now has 4.12.6-1 just like testing & sid.

#19 Updated by intrigeri over 2 years ago

intrigeri wrote:

Next step: install from stretch-backports, that now has 4.12.6-1 just like testing & sid.

Ouch, too early. Once binary packages have been built & installed, cherry-pick commit:7df904cdaec282e95814b574c06bc2195dfb0433.

#20 Updated by intrigeri over 2 years ago

  • % Done changed from 20 to 30

I've seen the full test suite pass locally on this branch (except the failure that's expected due to #14586). The subset of the test suite we run on lizard passed 3 times in a row. Now running the full test suite on lizard (we can't compare the results with anything but it might highlight regressions I've missed so far). Once I'm happy with these results I'll submit for QA (with our without the commit to pull the Linux packages from stretch-backports, depending on https://buildd.debian.org/status/package.php?p=linux&suite=stretch-backports).

#21 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 30 to 50
  • QA Check set to Ready for QA

#22 Updated by anonym over 2 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#23 Updated by anonym over 2 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF