Project

General

Profile

Feature #12729

Feature #12562: Have a web analytics platform like Matomo

Single out Tor Browser users in Matomo

Added by sajolida over 2 years ago. Updated 7 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/17/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

Description

To summarize our options, the pros and cons, to single out, at least partly, Tor Browser users:

1. Use server log with IP addresses

- (+) Will take into account people without JavaScript.
- (-) People going out through the same exit node will appear as a
single visit.

2. Use the JavaScript and cookie from Piwik

- () We won't take into account people without JavaScript.
() Have to add a consent message as of the Cookie Law.
(+) Will be able to differentiate Tor Browser users going out through
the same exit node.

3. Use the JavaScript only from Piwik

- () We won't take into account people without JavaScript.
() Probably won't be able to differentiate Tor Browser users going out through the same exit node.
- (
) Don't have to change our current server log policy (= bother boum.org).

In all cases, we can use the IP anonymization feature of Piwik on top of that (and delete the server logs for example).

Temporary conclusion: Options 1 and 3 seems the best options given the European legislation. 1 would take into account people without JavaScript so might be better on the long term. But 3 doesn't imply changes on boum.org so could be done right now.

History

#1 Updated by sajolida over 2 years ago

  • Parent task set to #12562

#2 Updated by sajolida over 2 years ago

#3 Updated by u about 2 years ago

  • Assignee set to sajolida
  • QA Check set to Info Needed

@sajolida Can you please clarify what this ticket is about?

#4 Updated by sajolida about 2 years ago

#5 Updated by sajolida about 2 years ago

#7 Updated by sajolida about 2 years ago

  • Description updated (diff)

#8 Updated by sajolida almost 2 years ago

  • Description updated (diff)
  • QA Check deleted (Info Needed)

#9 Updated by sajolida almost 2 years ago

#10 Updated by sajolida almost 2 years ago

  • Description updated (diff)

Update: you can use the JavaScript from Piwik without the cookie. See https://piwik.org/faq/general/faq_157/. Then we can use the JavaScript, not have to deal with a change of policy in our logs, and still comply with the European GDPR.

#11 Updated by sajolida almost 2 years ago

Actually, even the JavaScript only might not be enough but it's not clear yet. See "2 – You are not collecting personal data with Piwik" in https://piwik.org/blog/2017/09/gdpr-potential-consequences-piwik/?pk_campaign=org_newsletter_2017_10&pk_medium=email&pk_source=piwik_org_newsletter.

#12 Updated by sajolida over 1 year ago

  • Subject changed from Single out Tor Browser users in Piwik to Single out Tor Browser users in Matomo

#13 Updated by sajolida 7 months ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (sajolida)

I'm rejecting because I don't think we'll work on this any time soon.

Also available in: Atom PDF