Project

General

Profile

Bug #12695

Improve Ubuntu installation instructions

Added by cbrownstein over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
06/14/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Yes
Affected tool:
Installation Assistant

Description

https://tails.boum.org/install/debian/usb/index.en.html

2/6. Install Tails Installer ▸ If you are running Ubuntu ▸ 2. Open a Root Terminal.

No Root Terminal is installed, at least not on a fresh install of Ubuntu GNOME 17.04. Or if it is installed, I think we need to explain better how to open it.

Maybe instead we should explain how to add the tails-installer PPA through the graphical Software & Updates application?


Related issues

Related to Tails - Feature #11378: Make Tails Installer installable through Ubuntu Software Rejected 05/09/2016
Blocks Tails - Feature #13423: Core work 2017Q3: Technical writing Resolved 07/05/2017

History

#1 Updated by u over 2 years ago

  • Status changed from New to Confirmed
  • QA Check set to Info Needed
  • Affected tool set to Installation Assistant

Thanks for reporting this documentation issue.

It seems indeed that we should either tell people how to

  • open Gnome Terminal and `sudo -s`
  • run `gksudo gnome-terminal`

OR

  • explain them how to add the PPA through a graphical interface, which would be even nicer IMO.

@cbrownstein: are you willing to research this, and update the part of the documentation which is misleading? If yes, please unset the "Info Needed" in the "QA check" field. If not, please assign this ticket to sajolida, so that he can decide what to do about it.
Thank you!

#2 Updated by u over 2 years ago

  • Subject changed from Install from Ubuntu instructions reference nonexistent Root Terminal to Improve Ubuntu installation instructions

#3 Updated by cbrownstein over 2 years ago

  • Status changed from Confirmed to In Progress
  • QA Check deleted (Info Needed)

I can take care of this ticket, not a problem.

#4 Updated by sajolida over 2 years ago

  • Related to Feature #11378: Make Tails Installer installable through Ubuntu Software added

#5 Updated by sajolida over 2 years ago

Cody: See #11378. Tails Installer is not installable through Software & Updates and Ubuntu Software.

For this ticket, what about instructing to use sudo in front of each command line? That's quick and a quite common practice in other Ubuntu documentation, no?

#6 Updated by cbrownstein over 2 years ago

sajolida: I'm pretty sure you're correct that the Tails Installer cannot be installed through the graphical software managers you mention. If I was unclear previously, I meant only that the Tails PPA be configured through Software & Updates. The current instructions have the user use add-apt-repository.

My suggestion is that the Tails PPA be configured through Software & Updates. From there, instruct the user to sudo apt install tails-installer. (Maybe sudo apt update as well. I'll have to test when I have a bit more time.)

#7 Updated by cbrownstein over 2 years ago

I just tested quickly on my Ubuntu GNOME 17.04 system. Basically, the instructions are as follows:

  1. Start Software & Updates
  2. Choose Other Software
  3. Click Add...
  4. Enter ppa:tails-team/tails-installer
  5. Click Close
  6. You'll be prompted to update your list of available packages
  7. In a terminal, run sudo apt install tails-installer

#8 Updated by u over 2 years ago

Hi, great, this sounds like non power users can do it! I let sajolida find ou where to document that.

#9 Updated by cbrownstein over 2 years ago

  • Assignee changed from cbrownstein to sajolida
  • QA Check set to Ready for QA

https://github.com/cbrownstein/tails/tree/doc/12695-improve-ubuntu-install-instructions

For the most part, the Ubuntu install instructions are already documented in the Debian install instructions.

#10 Updated by sajolida over 2 years ago

  • Target version set to Tails_3.1

#11 Updated by sajolida over 2 years ago

#12 Updated by sajolida over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

Cool! You were perfectly right in updating the Software & Updates part but not the APT part; I overlooked this initially.

The rest is good and I'm merging.

It's good that you copy the formulation from Debian as much as possible because it will hopefully save the translators some work. I updated one phrasing in ef0a271a98, but only because I love nitpicking :)

Also available in: Atom PDF