Project

General

Profile

Feature #12694

Tails-Upgrader: long pause between downloading and 'restart tails' windows

Added by muri over 2 years ago. Updated about 2 years ago.

Status:
Confirmed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
06/13/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Upgrader

Description

while doing an upgrade to 3.0 (from rc1) i noticed, that there is a long time between the window that shows the download process and the notification, which says that the device was successfully upgraded. in this time there is no indication that there is still something happening. i had to open a terminal and start 'top' to see that there is indeed some process that could have something to do with the upgrade process.
i think it would be great to have at least some window with some clue that work is being done in the background.

History

#1 Updated by intrigeri over 2 years ago

  • Assignee set to muri
  • QA Check set to Info Needed
  • Affected tool set to Upgrader

while doing an upgrade to 3.0 (from rc1) i noticed, that there is a long time between the window that shows the download process and the notification, which says that the device was successfully upgraded. in this time there is no indication that there is still something happening.

Wait, between the "Downloading the upgrade" dialog and the restart one, there should be one saying "Your Tails device is being upgraded...", so I wonder: didn't you see that one at all, or perhaps pressed escape, or maybe the problem you're describing happens after "Your Tails device is being upgraded..." has closed and before you're told you can restart?

#2 Updated by muri over 2 years ago

  • Assignee changed from muri to intrigeri
  • QA Check changed from Info Needed to Dev Needed

intrigeri wrote:

Wait, between the "Downloading the upgrade" dialog and the restart one, there should be one saying "Your Tails device is being upgraded...", so I wonder: didn't you see that one at all, or perhaps pressed escape, or maybe the problem you're describing happens after "Your Tails device is being upgraded..." has closed and before you're told you can restart?

i just tried again: the "Downloading the upgrade" dialog disappears, then there is movement in the upper right corner (i guess the wifi is disabled), the fan starts running faster and after 2 minutes i get the 'Restart Tails' dialog. There is no 'Your Tails device is being upgraded...' notification.

#3 Updated by intrigeri over 2 years ago

  • Target version set to Tails_3.1

Thanks a lot for retrying, I'll look into it!

#4 Updated by intrigeri about 2 years ago

  • Category deleted (Accessibility)
  • Status changed from New to Confirmed
  • Assignee deleted (intrigeri)
  • Target version deleted (Tails_3.1)

Nobody else reported this, perhaps it's fine as long as it works in the end => at the help desk / foundations team meeting today, we deemed this ticket as low priority => dropping from my plate so I can focus on other things.

#5 Updated by u about 2 years ago

  • Priority changed from Normal to Low

#6 Updated by u about 2 years ago

  • QA Check deleted (Dev Needed)

#7 Updated by intrigeri about 2 years ago

Upgrading 3.0 to 3.0.1 in order to reproduce #13426, I thought I would at least report what I see here:

  1. "Downloading upgrade" dialog
  2. then indeed a couple minutes pause without any feedback
  3. finally the "Restart Tails" dialog

I.e. exactly what muri described.

In the Journal I see:

Jul 06 16:38:47 amnesia sudo[10348]: pam_unix(sudo:session): session closed for user tails-iuk-get-target-file
Jul 06 16:38:47 amnesia tails-upgrade-frontend-wrapper[10101]: <b>Your Tails device is being upgraded...</b>
Jul 06 16:38:47 amnesia tails-upgrade-frontend-wrapper[10101]: For security reasons, the networking is now disabled.
Jul 06 16:38:47 amnesia tails-upgrade-frontend-wrapper[10101]: Shutting down network connection
Jul 06 16:38:47 amnesia sudo[10635]: tails-upgrade-frontend : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/bin/tails-shutdown-network
Jul 06 16:38:47 amnesia sudo[10635]: pam_unix(sudo:session): session opened for user root by (uid=0)
Jul 06 16:38:47 amnesia systemd[1]: Stopping Anonymizing overlay network for TCP...

… and then some zenity errors (that I also see for dialogs that do appear) with a PID that matches none of the PIDs used by the zenity instances I can see. So at least zenity is called by tails-upgrade-frontend. Perhaps with wrong arguments?

Also available in: Atom PDF