Project

General

Profile

Bug #12684

Update config/build-manifest-extra-packages.yml

Added by intrigeri over 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
06/12/2017
Due date:
% Done:

100%

Feature Branch:
bugfix/12684-update-build-manifest-extra-packages
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

E.g. it references a version of squashfs-tools (1:4.2+20130409-2) that we probably don't use anymore.


Related issues

Blocks Tails - Feature #13234: Core work 2017Q3: Foundations Team Resolved 06/29/2017

Associated revisions

Revision 2cfb9c98 (diff)
Added by intrigeri over 2 years ago

build-manifest-extra-packages.yml: remove squashfs-tools version we don't use anymore (refs: #12684).

Apparently our apt-get/debootstrap wrapper tricks are enough to detect the
version of squashfs-tools we actually install and use: I see it in
tails-amd64-3.0.build-manifest, while it's only installed by lb_binary_rootfs..

Revision 4dbfdf05
Added by anonym about 2 years ago

Merge remote-tracking branch 'origin/bugfix/12684-update-build-manifest-extra-packages' into devel

Fix-committed: #12684

History

#1 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress
  • Target version changed from Tails_3.1 to Tails_3.2
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/12684-update-build-manifest-extra-packages

Indeed, at first glance it seems we have a problem here:

reprepro-tagged-snapshots@apt:~/repositories/3.0$ find . -name squashfs*
./debian/pool/main/s/squashfs-tools
./debian/pool/main/s/squashfs-tools/squashfs-tools_4.2+20130409-2.dsc
./debian/pool/main/s/squashfs-tools/squashfs-tools_4.2+20130409-2_i386.deb
./debian/pool/main/s/squashfs-tools/squashfs-tools_4.2+20130409.orig.tar.xz
./debian/pool/main/s/squashfs-tools/squashfs-tools_4.2+20130409-2.debian.tar.xz
./debian/pool/main/s/squashfs-tools/squashfs-tools_4.2+20130409-2_amd64.deb

OTOH we don't include packages coming from our custom APT repo in tagged snapshots, so as long as we use a custom squashfs-tools package, we're good. And even once we switch to a squashfs-tools from Debian, we're good as well since the version we really use is actually identified by our apt-get wrapper, and included in the build manifest:

  - arch: amd64
    package: squashfs-tools
    version: 1:4.2+20130409-2
  - arch: amd64
    package: squashfs-tools
    version: 1:4.3-3.0tails4

I think this demonstrates that the "pulled by lb_binary_rootfs, outside of the reach of our apt-get wrapper" comment and the rationale for 0dcf467e25dda7d2ee33142806e45ca236b35927 are actually wrong: we wrap apt-get before live-build creates the chroot, so it'll save whatever packages are installed in there, including those installed outside of the chroot copy (chroot/chroot), e.g. by lb_binary_rootfs and lb_binary_iso. I admit I'm afraid I might be missing something though: I'm pretty sure these changes did fix a real problem when I applied them a year ago, but OTOH I don't think reverting them can break anything on the short term, as we'll likely keep using a custom squashfs-tools for a while, so I'll go ahead.

#2 Updated by intrigeri over 2 years ago

Let's not take any bet for 3.1 though: I'd rather not see an inexperienced RM hit any problem caused by my changes :)

#4 Updated by intrigeri about 2 years ago

#5 Updated by anonym about 2 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#6 Updated by anonym almost 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF