Project

General

Profile

Bug #12655

Build instructions are broken on Jessie

Added by intrigeri over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
06/08/2017
Due date:
% Done:

100%

Feature Branch:
Type of work:
Contributors documentation
Blueprint:
Starter:
Affected tool:

Description

The following packages have unmet dependencies:                                            
  vagrant-libvirt : Depends: ruby-fog-libvirt (>= 0.3.0) but it is not going to be installed

ruby-fog-libvirt/stretch depends on Stretch's Ruby, that IMO we should not try installing on Jessie.

IMO the best fix is to simply require Stretch.


Related issues

Duplicated by Tails - Bug #12716: https://tails.boum.org/contribute/build/ fails by default Duplicate 06/15/2017
Blocks Tails - Feature #13234: Core work 2017Q3: Foundations Team Resolved 06/29/2017

Associated revisions

Revision ba354ded (diff)
Added by anonym over 2 years ago

Require >= Debian Stretch when building Tails.

Fix-committed: #12655

History

#1 Updated by intrigeri over 2 years ago

  • Duplicated by Bug #12716: https://tails.boum.org/contribute/build/ fails by default added

#2 Updated by intrigeri over 2 years ago

#3 Updated by anonym over 2 years ago

IMO the best fix is to simply require Stretch.

ACK, this is what I'll do.

#4 Updated by anonym over 2 years ago

  • Target version changed from Tails_3.1 to Tails_3.2

#5 Updated by intrigeri over 2 years ago

  • Target version changed from Tails_3.2 to Tails_3.1

(As per discussion on the CI team meeting today.)

#6 Updated by anonym over 2 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100

Fixed in ba354ded4480899831fd0646a3279d3943b49589 which is pushed => live on the website.

Also available in: Atom PDF