Project

General

Profile

Feature #12644

Allow remembering boot options

Added by elouann over 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Persistence
Target version:
-
Start date:
06/06/2017
Due date:
% Done:

0%

Feature Branch:
Type of work:
User interface design
Blueprint:
Starter:
Affected tool:

Description

A user asked to make Tails able to remember boot options, to avoid retyping them at each boot.
So here is the corresponding ticket


Related issues

Related to Tails - Feature #5501: Persistence preset: locale and accessibility options (language, keyboard, and formats) in Greeter Confirmed 12/31/2015
Related to Tails - Feature #10286: Boot options documentation: more options could be added Rejected 09/27/2015
Related to Tails - Bug #12474: Document troubleshooting tips for more failure scenarios throughout installation assistant Rejected 12/05/2017

History

#1 Updated by elouann over 2 years ago

  • Related to Feature #5501: Persistence preset: locale and accessibility options (language, keyboard, and formats) in Greeter added

#2 Updated by intrigeri over 2 years ago

  • Category set to Persistence
  • Priority changed from Normal to Low

I think there's a way to do this, but it'll require quite some work (days).
Anyone, feel free to make a good case about why this request is worth this much effort.

#3 Updated by sajolida over 2 years ago

  • Related to Feature #10286: Boot options documentation: more options could be added added

#4 Updated by sajolida over 2 years ago

  • Related to Bug #12474: Document troubleshooting tips for more failure scenarios throughout installation assistant added

#5 Updated by sajolida over 2 years ago

I do this on my Tails but editing the syslinux menu file from another Tails. So an alternative would be to document this. It might not even require going on the command line.

Now, I'm not convinced it's worth it (and it might definitely be dangerous for people to do so) but I don't have much data regarding which boot options people have to enter each time these days (and whether we should instead put our energy in fixing the root cause that require people to edit boot options).

So, a bit like for #12474, I'm personally lacking information on which boot options are worth being documented. For example, seeing this only from very very far away it seems like people had to add many options related to graphics in the late days of the 2.x serie and the beta day of the 3.x serie but the final goal is to have graphics work for everybody out-of-box.

More info regarding boot option usage would be useful for this ticket as well as for #12474 and I think that it should be the responsability of help desk to clarify this as explained in #12474#note-11.

#6 Updated by intrigeri over 2 years ago

For example, seeing this only from very very far away it seems like people had to add many options related to graphics in the late days of the 2.x serie and the beta day of the 3.x serie but the final goal is to have graphics work for everybody out-of-box.

Absolutely! One concern of mine is that if we make it too easy to customize boot options forever in order to workaround such issues, we'll get less bugs reported (⇒ no chance we ever find+fix the root cause, no chance we add to the known issues page) and we'll never learn when the workaround is not needed anymore (⇒ no chance to clean up the known issues page). OTOH most such problems are out of our reach, pretty often we can't do anything about them but help the bug reporter report the bug upstream, which rarely happens.

#7 Updated by u over 2 years ago

  • Tracker changed from Bug to Feature

#8 Updated by u over 2 years ago

  • Assignee set to sajolida

I think this is only a power user option, for the abovementioned reasons. It might be sufficient to document to do this here, on this ticket. And then mark the ticket as resolved. What do you think?

#9 Updated by u about 2 years ago

ping @sajolida?

#10 Updated by u about 2 years ago

  • Type of work changed from Code to User interface design

#11 Updated by sajolida almost 2 years ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (sajolida)

For me it's not a feature for power users but as a feature to fix hardware compatibility issues. But as intrigeri said the cost is probably high and the benefits unclear, so let's reject this for now.

Also available in: Atom PDF