Project

General

Profile

Bug #12620

Feature #5630: Reproducible builds

/usr/local/lib/tor-browser/omni.ja embeds build timestamp

Added by intrigeri over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/31/2017
Due date:
% Done:

100%

Feature Branch:
bugfix/12620-omni.ja-reproducibility-fix
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

I guess this reproducibility regression was caused by the hacks we had to do for Tor Browser 7.0.

Associated revisions

Revision ae3524db (diff)
Added by anonym over 2 years ago

Tor Browser: make our omni.ja modifications reproducible.

Will-fix: #12620

Revision 7c0e5aed
Added by intrigeri over 2 years ago

Merge remote-tracking branch 'origin/bugfix/12620-omni.ja-reproducibility-fix' into testing (Fix-committed: #12620)

History

#1 Updated by anonym over 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to intrigeri
  • Target version set to Tails_3.0
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/12620-omni.ja-reproducibility-fix

The feature branch fixes this for me locally. Please review'n'merge into testing!

#2 Updated by intrigeri over 2 years ago

  • % Done changed from 50 to 60

I'm not quite sure why we need strip_nondeterminism_wrapper since we already set the correct timestamp on each modified file before including it in omni.ja, but whatever: code review passes! Set up https://jenkins.tails.boum.org/job/reproducibly_build_Tails_ISO_bugfix-12620-omni.ja-reproducibility-fix/ to check reproducibility.

#4 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to 11
  • % Done changed from 60 to 100

#5 Updated by intrigeri over 2 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#6 Updated by intrigeri over 2 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF