Project

General

Profile

Bug #12610

Install OnionShare from sid to fix the build of the devel branch

Added by intrigeri over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
05/27/2017
Due date:
% Done:

100%

Feature Branch:
bugfix/12610-onionshare-from-sid
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

We've got OnionShare removed from testing, so devel FTBFS as the package cannot be installed anymore.


Related issues

Blocks Tails - Bug #12609: Bump APT snapshots serial for 3.0: 2017-06-09 Resolved 05/27/2017

Associated revisions

Revision 91f1af0d (diff)
Added by intrigeri over 2 years ago

Install OnionShare from Debian sid (refs: #12610).

It's been removed from Debian testing.

Revision 7c9e76fc
Added by anonym over 2 years ago

Merge remote-tracking branch 'origin/bugfix/12610-onionshare-from-sid' into testing

Fix-committed: #12610

Revision fc8d5135 (diff)
Added by anonym over 2 years ago

Drop now irrelevant build hook causing FTBFS.

... due to torbrowser-launcher not being installed any more at this
stage, resulting in trying to create a fake pacjage wutg an invalid
version number. OnionShare stopped depending on
torbrowser-launcher (refs: #12610) so we don't need to satisy this
dependency with a fake package any more.

Revision f9941c1c (diff)
Added by anonym over 2 years ago

Fetch the torbrowser-launcher sources from Debian sid.

It's been removed from Debian testing (along with OnionShare, refs: #12610).

History

#1 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/12610-onionshare-from-sid

#2 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

#3 Updated by intrigeri over 2 years ago

  • Blocks Bug #12609: Bump APT snapshots serial for 3.0: 2017-06-09 added

#4 Updated by anonym over 2 years ago

  • Status changed from In Progress to 11
  • Assignee changed from anonym to intrigeri
  • % Done changed from 50 to 100

I had to follow up with these commits:

commit f9941c1c778d6869ac6f62de437aceb5b1393c47
Author: anonym <anonym@riseup.net>
Date:   Mon May 29 20:34:33 2017 +0200

    Fetch the torbrowser-launcher sources from Debian sid.

    It's been removed from Debian testing (along with OnionShare, refs: #12610).

commit fc8d513540b414d4684a87de4e29cb0ec8e34ba0
Author: anonym <anonym@riseup.net>
Date:   Mon May 29 18:28:36 2017 +0200

    Drop now irrelevant build hook causing FTBFS.

    ... due to torbrowser-launcher not being installed any more at this
    stage, resulting in trying to create a fake pacjage wutg an invalid
    version number. OnionShare stopped depending on
    torbrowser-launcher (refs: #12610) so we don't need to satisy this
    dependency with a fake package any more.

Please have a look and make sure they are sane!

#5 Updated by intrigeri over 2 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Looks OK to me, modulo quite a few obvious typos in the commit message; please proof-read such stuff a bit carefully when you push straight to a base branch without review :) Anyway, thanks!

#6 Updated by anonym over 2 years ago

  • Status changed from 11 to In Progress

#7 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to 11

#8 Updated by intrigeri over 2 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF